Skip to content

← Actionable
Unratedamended

justhtml includes multiple security fixes

CVE-2026-5388GHSA-c9vm-hv86-f23r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (justhtml 1.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI justhtml

    Affected
    <= 1.14.0
    Fixed in
    1.15.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-5388: 0.59% estimated exploitation activity in the next 30 days; percentile 48.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary justhtml 1.15.0 includes multiple security fixes affecting URL sanitization helpers, HTML serialization, Markdown passthrough, and several custom sanitization-policy edge cases. These issues have different impact levels and do not all affect the default configuration in the same way. Affected versions - justhtml <= 1.14.0 Fixed version - justhtml 1.15.0 released on April 9, 2026 Impact overview Helper and serialization issues These issues could affect applications using JustHTML helpers or programmatic DOM construction, even outside the default HTML sanitization path. - JustHTML.cleanurlvalue(...) and cleanurlinjsstring(...) could accept URL values such as javascript&#58..., which became active javascript: URLs after HTML attribute parsing. - URL sanitization could treat values like \\evil.example/x or /\\evil.example/x as safe relative URLs even though browsers could resolve them as remote requests. - Malformed bracketed hosts such as https://[evil.example]/x could raise…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c9vm-hv86-f23r

  2. Revision 1 · created ·

    Published from osv record GHSA-c9vm-hv86-f23r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-5388

Advisory: justhtml includes multiple security fixes
IDs: CVE-2026-5388, GHSA-c9vm-hv86-f23r
Record: https://patchnext.com/advisories/cve-2026-5388 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: justhtml 1.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI justhtml: affected <= 1.14.0; fixed in 1.15.0

## Suggested inspection (read-only)
- `python -m pip show justhtml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on justhtml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c9vm-hv86-f23r (OSV record GHSA-c9vm-hv86-f23r lists affected ranges: PyPI justhtml >=0 <1.15.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c9vm-hv86-f23r (GitHub-reviewed advisory GHSA-c9vm-hv86-f23r lists affected ranges: PyPI justhtml >=0 <=1.14.0)

Commands are suggestions: review each one before running it.

Loading voting…