Skip to content

← Actionable
High, CVSS 7.1amended

OpenClaw: Linux and macOS exec allowlists skipped configured argument patterns

CVE-2026-53853GHSA-v2ww-5rh7-2h5v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.5.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.5.12
    Fixed in
    2026.5.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-53853: 0.35% estimated exploitation activity in the next 30 days; percentile 28.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary OpenClaw's exec allowlist supported optional argPattern entries to restrict the arguments accepted for an allowlisted executable. In affected releases, Linux and macOS gateways skipped argPattern checks and treated a matching executable path as sufficient to satisfy the allowlist. This meant an operator could configure an allowlist entry that appeared to permit only a narrow argv shape, but OpenClaw would allow other argv for the same executable without an approval prompt when tools.exec.security was set to allowlist. This issue is limited to direct enforcement of configured argPattern values. OpenClaw's exec approvals remain best-effort guardrails and do not attempt to semantically model every interpreter, loader, package script, shell feature, or transitive file a command may use. Affected configurations This affects OpenClaw gateway deployments that meet all of these conditions: - the gateway runs on Linux or macOS - exec is configured with tools.exec.security: "allowlist"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v2ww-5rh7-2h5v

  2. Revision 1 · created ·

    Published from osv record GHSA-v2ww-5rh7-2h5v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53853

Advisory: OpenClaw: Linux and macOS exec allowlists skipped configured argument patterns
IDs: CVE-2026-53853, GHSA-v2ww-5rh7-2h5v
Record: https://patchnext.com/advisories/cve-2026-53853 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.5.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.5.12; fixed in 2026.5.12

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v2ww-5rh7-2h5v (OSV record GHSA-v2ww-5rh7-2h5v lists affected ranges: npm openclaw >=0 <2026.5.12 (fixed))
- Verified: https://github.com/advisories/GHSA-v2ww-5rh7-2h5v (GitHub-reviewed advisory GHSA-v2ww-5rh7-2h5v lists affected ranges: npm openclaw >=0 <2026.5.12)

Commands are suggestions: review each one before running it.

Loading voting…