OpenClaw: Trusted-proxy Control UI WebSocket accepted client-declared scopes before pairing
CVE-2026-53821GHSA-qjpc-qf9m-xwmr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.5.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.5.18
- Fixed in
- 2026.5.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qjpc-qf9m-xwmr lists affected ranges: npm openclaw >=0 <2026.5.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qjpc-qf9m-xwmr lists affected ranges: npm openclaw >=0 <2026.5.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-53821: 0.29% estimated exploitation activity in the next 30 days; percentile 21.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In trusted-proxy Control UI mode, OpenClaw accepted a WebSocket client's declared operator scopes before those scopes were bound to a server-approved pairing or trusted-proxy authorization baseline. This issue affects trusted-proxy Control UI deployments. It does not apply to shared-secret Control UI sessions, which are treated as trusted operator sessions by design. Affected configurations This affects deployments using gateway.auth.mode: "trusted-proxy" for Control UI access where a restricted trusted-proxy user could open a Control UI WebSocket and present a fresh, unpaired device identity with elevated requested scopes. Impact An unpaired or restricted trusted-proxy Control UI client could obtain cached operator.admin authority on its live WebSocket connection. That authority could then be used for admin-gated Gateway RPCs until the connection was closed or revalidated. Patched Versions The first stable patched version is 2026.5.18. Mitigations Upgrade to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qjpc-qf9m-xwmr
- Revision 1 · created ·
Published from osv record GHSA-qjpc-qf9m-xwmr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53821 Advisory: OpenClaw: Trusted-proxy Control UI WebSocket accepted client-declared scopes before pairing IDs: CVE-2026-53821, GHSA-qjpc-qf9m-xwmr Record: https://patchnext.com/advisories/cve-2026-53821 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.5.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.5.18; fixed in 2026.5.18 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qjpc-qf9m-xwmr (OSV record GHSA-qjpc-qf9m-xwmr lists affected ranges: npm openclaw >=0 <2026.5.18 (fixed)) - Verified: https://github.com/advisories/GHSA-qjpc-qf9m-xwmr (GitHub-reviewed advisory GHSA-qjpc-qf9m-xwmr lists affected ranges: npm openclaw >=0 <2026.5.18) Commands are suggestions: review each one before running it.
Loading voting…