Avo: Direct attachment upload endpoint lacks upload authorization and bypasses field-level upload policy
CVE-2026-53769GHSA-pqpw-cvm4-8mv9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (avo 3.32.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems avo
- Affected
- >= 2.28.0, < 3.32.0
- Fixed in
- 3.32.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pqpw-cvm4-8mv9 lists affected ranges: RubyGems avo >=2.28.0 <3.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-53769: 0.42% estimated exploitation activity in the next 30 days; percentile 36.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Avo's direct attachment upload endpoint lacks server-side upload authorization and bypasses the documented field-level upload policy methods such as upload{FIELDID}?. An authenticated Avo user who can reach the Avo attachment upload endpoint can replace or add attachment content, including binary content, filename, and content-type metadata, on a resolved record even when both update? and upload<field? policies deny the operation. This primarily affects multi-role Avo Pro/Advanced-style deployments where non-administrator or restricted operator users can reach Avo and per-record or per-field operations are expected to be enforced by policies. Details Avo exposes a direct attachment upload endpoint: The vulnerable code path is Avo::AttachmentsController#create: - app/controllers/avo/attachmentscontroller.rb:9-24 Current behavior: This endpoint creates an ActiveStorage::Blob before validating the requested attachment association and before any upload authorization could be…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pqpw-cvm4-8mv9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53769 Advisory: Avo: Direct attachment upload endpoint lacks upload authorization and bypasses field-level upload policy IDs: CVE-2026-53769, GHSA-pqpw-cvm4-8mv9 Record: https://patchnext.com/advisories/cve-2026-53769 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: avo 3.32.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems avo: affected >= 2.28.0, < 3.32.0; fixed in 3.32.0 ## Suggested inspection (read-only) - RubyGems avo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on avo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pqpw-cvm4-8mv9 (GitHub-reviewed advisory GHSA-pqpw-cvm4-8mv9 lists affected ranges: RubyGems avo >=2.28.0 <3.32.0) Commands are suggestions: review each one before running it.
Loading voting…