Skip to content

← Actionable
Low, CVSS 2.0amended

Linuxfabrik Monitoring Plugins allow insecure creation of SQLite databases

CVE-2026-53759GHSA-r35r-fpx2-jgr4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (linuxfabrik-lib 4.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-53759: 0.19% estimated exploitation activity in the next 30 days; percentile 8.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The SQLite databases are created at predictable (static) paths in /tmp. Any user can therefore create a symlink at these paths in /tmp pointing to arbitrary files. The monitoring scripts then follows these symlinks and then creates their database at the symlink target. This becomes really dangerous for the scripts which can be executed as root with sudo. With this, an attacker can write to abitrary paths. PoC The docker-stats check command here as an example. Because writing to /tmp is the default behaviour, the other check commands which use a SQLite database are also very likely affected. Check whether or not file was created. Impact In it's basic form, this vulnerbility can lead to a denial of service, impacting users who use the provided sudoers file and who didn't take any special precautions like systemd's PrivateTemp. It requires that an attacker already compromised the nagios account (which is quite a high barrier to be honest). If any application on the server relies…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r35r-fpx2-jgr4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r35r-fpx2-jgr4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53759

Advisory: Linuxfabrik Monitoring Plugins allow insecure creation of SQLite databases
IDs: CVE-2026-53759, GHSA-r35r-fpx2-jgr4
Record: https://patchnext.com/advisories/cve-2026-53759 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: linuxfabrik-lib 4.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI linuxfabrik-lib: affected < 4.2.0; fixed in 4.2.0

## Suggested inspection (read-only)
- `python -m pip show linuxfabrik-lib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on linuxfabrik-lib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r35r-fpx2-jgr4 (OSV record GHSA-r35r-fpx2-jgr4 lists affected ranges: PyPI linuxfabrik-lib >=0 <4.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-r35r-fpx2-jgr4 (GitHub-reviewed advisory GHSA-r35r-fpx2-jgr4 lists affected ranges: PyPI linuxfabrik-lib >=0 <4.2.0)

Commands are suggestions: review each one before running it.

Loading voting…