Skip to content

← Actionable
High, CVSS 7.5amended

Crawl4AI: SSRF filter bypass in Docker server via IPv6 transition forms (NAT64 / 6to4 / unspecified / v4-mapped)

CVE-2026-53754GHSA-4qqr-vv2q-cmr5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (crawl4ai 0.8.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI crawl4ai

    Affected
    <= 0.8.7
    Fixed in
    0.8.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-53754: 0.43% estimated exploitation activity in the next 30 days; percentile 37.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Docker API server's SSRF protection (validatewebhookurl / validateurldestination in deploy/docker/utils.py) used an explicit IPv4/IPv6 CIDR blocklist that missed several address families. An attacker could reach internal services and cloud metadata endpoints (e.g. 169.254.169.254) despite the filter by encoding an internal IPv4 address inside an IPv6 transition form, or by using the IPv6 unspecified address. Because the Docker API is unauthenticated by default (jwtenabled: false), no credentials are required. Affected paths The blocklist was applied to crawl URLs (POST /crawl, /md, /html, /screenshot, /pdf, /executejs) and webhook URLs (/crawl/job, /llm/job). All shared the same incomplete check. Bypasses The following all resolve to (or route to) blocked internal addresses but were NOT caught: - IPv6 unspecified :: - NAT64 64:ff9b::a9fe:a9fe (embeds 169.254.169.254) - 6to4 2002:a9fe:a9fe:: (embeds 169.254.169.254) - IPv4-mapped ::ffff:169.254.169.254 - IPv4-compatible…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4qqr-vv2q-cmr5

  2. Revision 1 · created ·

    Published from osv record GHSA-4qqr-vv2q-cmr5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53754

Advisory: Crawl4AI: SSRF filter bypass in Docker server via IPv6 transition forms (NAT64 / 6to4 / unspecified / v4-mapped)
IDs: CVE-2026-53754, GHSA-4qqr-vv2q-cmr5
Record: https://patchnext.com/advisories/cve-2026-53754 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: crawl4ai 0.8.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI crawl4ai: affected <= 0.8.7; fixed in 0.8.8

## Suggested inspection (read-only)
- `python -m pip show crawl4ai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on crawl4ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4qqr-vv2q-cmr5 (OSV record GHSA-4qqr-vv2q-cmr5 lists affected ranges: PyPI crawl4ai >=0 <0.8.8 (fixed))
- Verified: https://github.com/advisories/GHSA-4qqr-vv2q-cmr5 (GitHub-reviewed advisory GHSA-4qqr-vv2q-cmr5 lists affected ranges: PyPI crawl4ai >=0 <=0.8.7)

Commands are suggestions: review each one before running it.

Loading voting…