Skip to content

← Actionable
Critical, CVSS 9.8amended

Crawl4AI: AST Sandbox Escape via gi_frame.f_back Chain - Pre-Auth RCE in Docker API

CVE-2026-53753GHSA-qxjp-w3pj-48m7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (crawl4ai 0.8.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI crawl4ai

    Affected
    <= 0.8.6
    Fixed in
    0.8.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-53753: 2.90% estimated exploitation activity in the next 30 days; percentile 86.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The safeevalexpression() function in the computed fields feature uses an AST validator that only blocks attributes starting with underscore. Python generator and frame object attributes (giframe, fback, fbuiltins) do NOT start with underscore, enabling a complete sandbox escape to achieve arbitrary code execution. The attack requires no authentication (JWT disabled by default) and is triggered via POST /crawl with a crafted extraction schema. Attack Vector An attacker sends a POST /crawl request with a JsonCssExtractionStrategy schema containing a malicious computed field expression that: 1. Creates a generator to access giframe 2. Walks the frame chain via fback 3. Reaches fbuiltins containing the real import 4. Imports os and executes arbitrary commands Impact Unauthenticated remote code execution inside the Docker container. An attacker can execute arbitrary system commands, read/write files, and exfiltrate secrets. Fix Details 1. Removed eval() from computed field…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qxjp-w3pj-48m7

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qxjp-w3pj-48m7

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qxjp-w3pj-48m7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53753

Advisory: Crawl4AI: AST Sandbox Escape via gi_frame.f_back Chain - Pre-Auth RCE in Docker API
IDs: CVE-2026-53753, GHSA-qxjp-w3pj-48m7
Record: https://patchnext.com/advisories/cve-2026-53753 (revision 3, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: crawl4ai 0.8.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI crawl4ai: affected <= 0.8.6; fixed in 0.8.7

## Suggested inspection (read-only)
- `python -m pip show crawl4ai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on crawl4ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qxjp-w3pj-48m7 (GitHub-reviewed advisory GHSA-qxjp-w3pj-48m7 lists affected ranges: PyPI crawl4ai >=0 <=0.8.6)
- Verified: https://osv.dev/vulnerability/GHSA-qxjp-w3pj-48m7 (OSV record GHSA-qxjp-w3pj-48m7 lists affected ranges: PyPI crawl4ai >=0 <0.8.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…