Skip to content

← Actionable
High, CVSS 7.1

Medplum: Improper Validation of Redirect URI in External Auth Callback allows Authorization Code Leakage

CVE-2026-53728GHSA-m44r-7c5h-m6mj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@medplum/core 5.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-53728: 0.20% estimated exploitation activity in the next 30 days; percentile 9.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The external identity provider callback at GET /auth/external accepts attacker-controlled redirect URIs that only need to start with a registered client redirect URI, rather than matching exactly. After a successful external IdP login, the server appends Medplum login and code values to that attacker-supplied URL and issues a redirect. Because the external login request state is serialized as raw JSON and later trusted by the callback, an attacker who can tamper with state.redirectUri can cause Medplum to redirect authorization artifacts to an attacker-controlled endpoint. When the registered redirect URI is a bare origin or another prefix that can be extended into a different hostname, this becomes a cross-origin authorization code leak. Technical Explanation The vulnerable flow is exposed on the unauthenticated callback route GET /auth/external. In externalCallbackHandler(), the server parses the external auth state and uses the decoded clientId and redirectUri after…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m44r-7c5h-m6mj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53728

Advisory: Medplum: Improper Validation of Redirect URI in External Auth Callback allows Authorization Code Leakage
IDs: CVE-2026-53728, GHSA-m44r-7c5h-m6mj
Record: https://patchnext.com/advisories/cve-2026-53728 (revision 1, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @medplum/core 5.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @medplum/core: affected <= 5.1.5; fixed in 5.1.6

## Suggested inspection (read-only)
- `npm ls @medplum/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @medplum/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m44r-7c5h-m6mj (GitHub-reviewed advisory GHSA-m44r-7c5h-m6mj lists affected ranges: npm @medplum/core >=0 <=5.1.5)

Commands are suggestions: review each one before running it.

Loading voting…