Ruby CSS Parser: SSRF and Local File Disclosure in CssParser::Parser#read_remote_file
CVE-2026-53727GHSA-9pmc-p236-855h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (css_parser 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems css_parser
- Affected
- < 3.0.0
- Fixed in
- 3.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9pmc-p236-855h lists affected ranges: RubyGems css_parser >=0 <3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-53727: 0.51% estimated exploitation activity in the next 30 days; percentile 43.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary CssParser::Parser#readremotefile (and therefore loaduri!, and the @import-following branch of addblock!) issues HTTP/HTTPS requests against any host, port and URI it is handed, with no scheme allowlist, no host / IP filtering, and no protection against link-local, loopback or RFC‑1918 addresses. Location: redirects are followed recursively back into the same function, which also services file:// URIs, so a single attacker-controlled HTTP redirect upgrades the bug from SSRF to arbitrary local file disclosure. In practice, any consumer of cssparser that hands it attacker‑influenced CSS together with a baseuri: option — Premailer being the canonical example — is exposed. The attacker only needs the ability to land one @import url(...) in the CSS that the host application parses. Vulnerable code lib/cssparser/parser.rb#L613-L687: There is no validation of uri.host, uri.scheme, or the resolved IP address — neither before the HTTP request, nor before the recursive call on the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9pmc-p236-855h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53727 Advisory: Ruby CSS Parser: SSRF and Local File Disclosure in `CssParser::Parser#read_remote_file` IDs: CVE-2026-53727, GHSA-9pmc-p236-855h Record: https://patchnext.com/advisories/cve-2026-53727 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: css_parser 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems css_parser: affected < 3.0.0; fixed in 3.0.0 ## Suggested inspection (read-only) - RubyGems css_parser: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on css_parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9pmc-p236-855h (GitHub-reviewed advisory GHSA-9pmc-p236-855h lists affected ranges: RubyGems css_parser >=0 <3.0.0) Commands are suggestions: review each one before running it.
Loading voting…