Skip to content

← Actionable
Medium, CVSS 6.9amended

parse-server: Relation $relatedTo query bypasses protectedFields and owning-object ACL

CVE-2026-53726GHSA-wmwx-jr2p-4j4r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.9.1-alpha.6, 8.6.80), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 9.0.0, < 9.9.1-alpha.6< 8.6.80
    Fixed in
    9.9.1-alpha.6, 8.6.80

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-53726: 0.28% estimated exploitation activity in the next 30 days; percentile 20.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A relation query using the $relatedTo operator could read the membership of a Relation field even when that field was hidden from the requesting client by protectedFields, and even when the object owning the relation was not readable by the client under its ACL or class-level permissions. The request requires only the public API credentials that Parse clients normally carry — no user session, master key, or Cloud Code is needed. As a result, an unauthenticated client who knows or obtains the owning object's objectId could enumerate the objects linked through a protected relation, or combine the operator with an objectId constraint to use it as a membership oracle — confirming whether a specific object is linked to a private parent. This affects applications that rely on protectedFields or object ACLs to keep Relation membership confidential, such as private group memberships, block lists, or account-to-resource associations. Patches The relation query path now authorizes…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wmwx-jr2p-4j4r

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wmwx-jr2p-4j4r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53726

Advisory: parse-server: Relation `$relatedTo` query bypasses `protectedFields` and owning-object ACL
IDs: CVE-2026-53726, GHSA-wmwx-jr2p-4j4r
Record: https://patchnext.com/advisories/cve-2026-53726 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 9.9.1-alpha.6, 8.6.80. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 9.0.0, < 9.9.1-alpha.6; < 8.6.80; fixed in 9.9.1-alpha.6, 8.6.80

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wmwx-jr2p-4j4r (OSV record GHSA-wmwx-jr2p-4j4r lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.80 (fixed))
- Verified: https://github.com/advisories/GHSA-wmwx-jr2p-4j4r (GitHub-reviewed advisory GHSA-wmwx-jr2p-4j4r lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.80)

Commands are suggestions: review each one before running it.

Loading voting…