parse-server: Stored XSS via trailing-dot filename bypassing file upload extension blocklist
CVE-2026-53724GHSA-7wqv-xjf3-x35v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.9.1-alpha.4, 8.6.79), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.9.1-alpha.4<= 8.6.78
- Fixed in
- 8.6.79, 9.9.1-alpha.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7wqv-xjf3-x35v lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.79 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7wqv-xjf3-x35v lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.78
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-53724: 0.28% estimated exploitation activity in the next 30 days; percentile 20.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The default file upload extension blocklist can be bypassed by appending a trailing dot to a filename whose extension would otherwise be blocked (e.g. poc.svg.). The trailing dot causes the extension parser to extract an empty string, which short-circuits the blocklist check, and the attacker-controlled Content-Type is forwarded to the storage adapter unchanged. Storage adapters that persist and serve the provided Content-Type (such as S3 or GCS) then serve the file with an active type such as image/svg+xml, enabling stored XSS when a victim opens the file URL. The default GridFS adapter is not affected because it sets X-Content-Type-Options: nosniff on responses. Patches A filename ending in a dot is now treated as extensionless. When the parser produces an empty extension, the request handler falls back to validating the Content-Type subtype against the configured extension blocklist, matching the path that already catches truly extensionless uploads with a dangerous…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7wqv-xjf3-x35v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7wqv-xjf3-x35v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53724 Advisory: parse-server: Stored XSS via trailing-dot filename bypassing file upload extension blocklist IDs: CVE-2026-53724, GHSA-7wqv-xjf3-x35v Record: https://patchnext.com/advisories/cve-2026-53724 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.9.1-alpha.4, 8.6.79. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.9.1-alpha.4; <= 8.6.78; fixed in 8.6.79, 9.9.1-alpha.4 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7wqv-xjf3-x35v (OSV record GHSA-7wqv-xjf3-x35v lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.79 (fixed)) - Verified: https://github.com/advisories/GHSA-7wqv-xjf3-x35v (GitHub-reviewed advisory GHSA-7wqv-xjf3-x35v lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.78) Commands are suggestions: review each one before running it.
Loading voting…