Skip to content

← Actionable
Medium, CVSS 5.8

guzzlehttp/guzzle-services' XML Request Serialization Vulnerable to XML Injection via CDATA Terminator

CVE-2026-53723GHSA-q8r6-5hfw-5jff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (guzzlehttp/guzzle-services 1.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
  • CVE-2026-53723: 0.22% estimated exploitation activity in the next 30 days; percentile 12.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact guzzlehttp/guzzle-services does not safely serialize scalar XML element values containing the CDATA terminator ]]. The XML request serializer writes values containing <, , or & with XMLWriter::writeCData($value). If attacker-controlled input contains ]], the CDATA section closes early and the remainder is interpreted as XML markup. This is an outgoing request-body integrity issue, not a response parsing issue. The attacker does not need to control the service description or schema. Users are affected when all of the following are true: 1. The application uses guzzlehttp/guzzle-services to serialize outgoing requests. 2. A request parameter or additionalParameters schema uses location: xml. 3. The value is serialized as XML element text, not an XML attribute. 4. The value can contain attacker-controlled, user-controlled, tenant-controlled, or otherwise untrusted input. 5. The value is not constrained by a safe enum, pattern, or custom filter that excludes ]]. 6. The downstream…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q8r6-5hfw-5jff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53723

Advisory: guzzlehttp/guzzle-services' XML Request Serialization Vulnerable to XML Injection via CDATA Terminator
IDs: CVE-2026-53723, GHSA-q8r6-5hfw-5jff
Record: https://patchnext.com/advisories/cve-2026-53723 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: guzzlehttp/guzzle-services 1.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist guzzlehttp/guzzle-services: affected < 1.5.4; fixed in 1.5.4

## Suggested inspection (read-only)
- Packagist guzzlehttp/guzzle-services: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on guzzlehttp/guzzle-services.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q8r6-5hfw-5jff (GitHub-reviewed advisory GHSA-q8r6-5hfw-5jff lists affected ranges: Packagist guzzlehttp/guzzle-services >=0 <1.5.4)

Commands are suggestions: review each one before running it.

Loading voting…