Envoy Gateway: Authentication Bypass via Improper Input Validation in EnvoyExtensionPolicy Lua Allows Secret Disclosure
CVE-2026-53713GHSA-wcrf-9vrr-854f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/envoyproxy/gateway 1.8.1, 1.7.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/envoyproxy/gateway
- Affected
- >= 1.8.0-rc.0, < 1.8.1< 1.7.4
- Fixed in
- 1.8.1, 1.7.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wcrf-9vrr-854f lists affected ranges: Go github.com/envoyproxy/gateway >=1.8.0-rc.0 =0 <1.7.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- EPSS
- CVE-2026-53713: 0.43% estimated exploitation activity in the next 30 days; percentile 37.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The toabsolutenormalizedpath function (security.lua:28-43) does not collapse redundant path separators (// → /). On Linux, //etc/passwd is equivalent to /etc/passwd (POSIX path semantics), but iscriticalpath fails to match the double-slash variant because //etc/passwd does not start with /etc/. This allows Lua code submitted as an EnvoyExtensionPolicy to read arbitrary files from the gateway controller pod's filesystem during Strict validation (the default), including: /etc/passwd Kubernetes SA tokens via //var/run/secrets/kubernetes.io/serviceaccount/token TLS certificates via //certs/... Process environment via //proc/self/environ These credentials can be used to read sensitive information from the K8s API Server or from the Gateway XDS server. Patches This has been patched in versions = v1.7.4 and v1.8.1 - Collapse redundant path separators (// to /) so double-slash variants like //etc/passwd and //var/run/secrets/... are matched by the critical-path check. - Rewrite the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wcrf-9vrr-854f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53713 Advisory: Envoy Gateway: Authentication Bypass via Improper Input Validation in EnvoyExtensionPolicy Lua Allows Secret Disclosure IDs: CVE-2026-53713, GHSA-wcrf-9vrr-854f Record: https://patchnext.com/advisories/cve-2026-53713 (revision 1, source checked 26 Oct 2026, 15:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/envoyproxy/gateway 1.8.1, 1.7.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/envoyproxy/gateway: affected >= 1.8.0-rc.0, < 1.8.1; < 1.7.4; fixed in 1.8.1, 1.7.4 ## Suggested inspection (read-only) - Go github.com/envoyproxy/gateway: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/envoyproxy/gateway. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wcrf-9vrr-854f (GitHub-reviewed advisory GHSA-wcrf-9vrr-854f lists affected ranges: Go github.com/envoyproxy/gateway >=1.8.0-rc.0 =0 <1.7.4) Commands are suggestions: review each one before running it.
Loading voting…