React Router: Potential CSRF via PUT/PATCH/DELETE document requests
CVE-2026-53663GHSA-84g9-w2xq-vcv6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-router 7.15.1; @remix-run/server-runtime 2.17.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm react-router
- Affected
- >= 7.12.0, < 7.15.1
- Fixed in
- 7.15.1
- Affected
- >= 2.17.3, < 2.17.5
- Fixed in
- 2.17.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-84g9-w2xq-vcv6 lists affected ranges: npm react-router >=7.12.0 =2.17.3 <2.17.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-84g9-w2xq-vcv6 lists affected ranges: npm react-router >=7.12.0 =2.17.3 <2.17.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-53663: 0.15% estimated exploitation activity in the next 30 days; percentile 4.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Certain CSRF checks in React Router v7 Framework Mode were insufficient and run on POST requests, but were bypassed on PUT/PATCH/DELETE requests. This is a low severity vulnerability because modern browser protections (CORS preflight, SameSite cookies) already block the cross-origin attack vectors that this missing CSRF check would otherwise gate. [!NOTE] This does not impact your React Router application if you are using Declarative Mode (<BrowserRouter) or Data Mode (createBrowserRouter/<RouterProvider).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-84g9-w2xq-vcv6
- Revision 1 · created ·
Published from osv record GHSA-84g9-w2xq-vcv6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53663 Advisory: React Router: Potential CSRF via PUT/PATCH/DELETE document requests IDs: CVE-2026-53663, GHSA-84g9-w2xq-vcv6 Record: https://patchnext.com/advisories/cve-2026-53663 (revision 2, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: react-router 7.15.1; @remix-run/server-runtime 2.17.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm react-router: affected >= 7.12.0, < 7.15.1; fixed in 7.15.1 - npm @remix-run/server-runtime: affected >= 2.17.3, < 2.17.5; fixed in 2.17.5 ## Suggested inspection (read-only) - `npm ls react-router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @remix-run/server-runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on react-router, @remix-run/server-runtime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-84g9-w2xq-vcv6 (OSV record GHSA-84g9-w2xq-vcv6 lists affected ranges: npm react-router >=7.12.0 =2.17.3 <2.17.5 (fixed)) - Verified: https://github.com/advisories/GHSA-84g9-w2xq-vcv6 (GitHub-reviewed advisory GHSA-84g9-w2xq-vcv6 lists affected ranges: npm react-router >=7.12.0 =2.17.3 <2.17.5) Commands are suggestions: review each one before running it.
Loading voting…