Prefect has Git Flag Injection via commit_sha and directories Parameters Leading to Remote Code Execution (RCE)
CVE-2026-5366GHSA-7pm4-56h2-5rxr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prefect 3.6.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI prefect
- Affected
- >= 3.1.11, < 3.6.25
- Fixed in
- 3.6.25
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7pm4-56h2-5rxr lists affected ranges: PyPI prefect >=3.1.11 <3.6.25
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7pm4-56h2-5rxr lists affected ranges: PyPI prefect >=3.1.11 <3.6.25 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-5366: 1.03% estimated exploitation activity in the next 30 days; percentile 63.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Prefect versions 3.1.11 through 3.6.24 are vulnerable to remote code execution due to improper handling of user-controlled input in the `GitRepository` storage class. The `commit_sha` parameter, which is passed to git commands, lacks validation and does not include a `--` separator to distinguish user input from git flags. This allows attackers to inject arbitrary git flags, such as `--upload-pack`, enabling execution of external programs. Additionally, the `directories` parameter can be exploited to inject git flags during sparse-checkout operations. These vulnerabilities allow any user with deployment creation permissions to execute arbitrary commands on worker machines, compromising shared work pools in multi-tenant environments.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-7pm4-56h2-5rxr
- Revision 1 · created ·
Published from ghsa record GHSA-7pm4-56h2-5rxr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-5366 Advisory: Prefect has Git Flag Injection via commit_sha and directories Parameters Leading to Remote Code Execution (RCE) IDs: CVE-2026-5366, GHSA-7pm4-56h2-5rxr Record: https://patchnext.com/advisories/cve-2026-5366 (revision 2, source checked 4 Nov 2026, 06:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prefect 3.6.25. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI prefect: affected >= 3.1.11, < 3.6.25; fixed in 3.6.25 ## Suggested inspection (read-only) - `python -m pip show prefect`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prefect. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7pm4-56h2-5rxr (GitHub-reviewed advisory GHSA-7pm4-56h2-5rxr lists affected ranges: PyPI prefect >=3.1.11 <3.6.25) - Verified: https://osv.dev/vulnerability/GHSA-7pm4-56h2-5rxr (OSV record GHSA-7pm4-56h2-5rxr lists affected ranges: PyPI prefect >=3.1.11 <3.6.25 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…