Fabric CA Developer's Guide: LDAP Injection via Unescaped Username in GetUser Filter
CVE-2026-53658GHSA-xghw-p77p-3r7x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hyperledger/fabric-ca 1.5.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/hyperledger/fabric-ca
- Affected
- <= 1.5.20
- Fixed in
- 1.5.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xghw-p77p-3r7x lists affected ranges: Go github.com/hyperledger/fabric-ca >=0 <1.5.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6234 lists affected ranges: Go github.com/hyperledger/fabric-ca >=0 <1.5.21 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xghw-p77p-3r7x lists affected ranges: Go github.com/hyperledger/fabric-ca >=0 <=1.5.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-53658: 0.45% estimated exploitation activity in the next 30 days; percentile 39.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When fabric-ca is configured with an LDAP backend, the username from HTTP Basic authentication is included in an LDAP uid search filter without proper escaping. An unauthenticated attacker with network access to the CA enrollment endpoint could exploit this to perform LDAP injection before password validation, and potentially steer authentication attempts toward a victim account. Recommendation - All users of fabric-ca with an LDAP backend should update to a fixed version. - For users not using an LDAP backend, no action is required.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-xghw-p77p-3r7x
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6234
- Revision 1 · created ·
Published from osv record GHSA-xghw-p77p-3r7x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53658 Advisory: Fabric CA Developer's Guide: LDAP Injection via Unescaped Username in GetUser Filter IDs: CVE-2026-53658, GHSA-xghw-p77p-3r7x Record: https://patchnext.com/advisories/cve-2026-53658 (revision 4, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hyperledger/fabric-ca 1.5.21. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hyperledger/fabric-ca: affected <= 1.5.20; fixed in 1.5.21 ## Suggested inspection (read-only) - Go github.com/hyperledger/fabric-ca: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hyperledger/fabric-ca. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xghw-p77p-3r7x (OSV record GHSA-xghw-p77p-3r7x lists affected ranges: Go github.com/hyperledger/fabric-ca >=0 <1.5.21 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6234 (OSV record GO-2026-6234 lists affected ranges: Go github.com/hyperledger/fabric-ca >=0 <1.5.21 (fixed)) - Verified: https://github.com/advisories/GHSA-xghw-p77p-3r7x (GitHub-reviewed advisory GHSA-xghw-p77p-3r7x lists affected ranges: Go github.com/hyperledger/fabric-ca >=0 <=1.5.20) Commands are suggestions: review each one before running it.
Loading voting…