Skip to content

← Actionable
Medium, CVSS 4.3

Sylius: Channel-based payment method restriction bypass on shop account orders API endpoint

CVE-2026-53638GHSA-6955-hrm5-c4qp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 2.2.6, 2.1.15, 2.0.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sylius/sylius

    Affected
    >= 2.0.0, < 2.0.18>= 2.1.0, < 2.1.15>= 2.2.0, < 2.2.6
    Fixed in
    2.0.18, 2.2.6, 2.1.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-53638: 0.28% estimated exploitation activity in the next 30 days; percentile 21.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authorization bypass vulnerability exists in the shop account API. The PATCH /api/v2/shop/account/orders/{tokenValue}/payments/{paymentId} endpoint, used by an authenticated shop customer to change the payment method of an order that has been placed but not yet paid (state STATENEW), does not validate that the chosen payment method is enabled for the order's channel. The equivalent checkout endpoint (PATCH /api/v2/shop/orders/{tokenValue}/payments/{paymentId}) correctly rejects out-of-channel payment methods with HTTP 422; the account endpoint silently accepts them and returns HTTP 200. An authenticated customer can therefore assign any globally enabled payment method to their own placed order, including methods that the store operator has explicitly excluded from that channel. Patches The issue is fixed in versions: 2.0.18, 2.1.15, 2.2.6 and above. Workarounds If users cannot bump Sylius right now, decorate the Sylius\Bundle\ApiBundle\Changer\PaymentMethodChangerInterface…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6955-hrm5-c4qp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53638

Advisory: Sylius: Channel-based payment method restriction bypass on shop account orders API endpoint
IDs: CVE-2026-53638, GHSA-6955-hrm5-c4qp
Record: https://patchnext.com/advisories/cve-2026-53638 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 2.2.6, 2.1.15, 2.0.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sylius/sylius: affected >= 2.0.0, < 2.0.18; >= 2.1.0, < 2.1.15; >= 2.2.0, < 2.2.6; fixed in 2.0.18, 2.2.6, 2.1.15

## Suggested inspection (read-only)
- Packagist sylius/sylius: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sylius/sylius.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6955-hrm5-c4qp (GitHub-reviewed advisory GHSA-6955-hrm5-c4qp lists affected ranges: Packagist sylius/sylius >=2.0.0 =2.1.0 =2.2.0 <2.2.6)

Commands are suggestions: review each one before running it.

Loading voting…