launch-editor: NTLMv2 hash disclosure via UNC path handling on Windows
CVE-2026-53632GHSA-v6wh-96g9-6wx3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 8.0.16, 7.3.5, 6.4.3; vite-plus 0.1.24; launch-editor 2.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vite
- Affected
- >= 8.0.0, <= 8.0.15>= 7.0.0, <= 7.3.4<= 6.4.2
- Fixed in
- 7.3.5, 8.0.16, 6.4.3
npm vite-plus
- Affected
- <= 0.1.23
- Fixed in
- 0.1.24
npm launch-editor
- Affected
- <= 2.14.0
- Fixed in
- 2.14.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v6wh-96g9-6wx3 lists affected ranges: npm launch-editor >=0 =8.0.0 =7.0.0 =0 =0 <0.1.24 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v6wh-96g9-6wx3 lists affected ranges: npm launch-editor >=0 =8.0.0 =7.0.0 =0 =0 <=0.1.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.5 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-53632: 0.41% estimated exploitation activity in the next 30 days; percentile 35.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The launch-editor NPM package accesses arbitrary paths including Windows UNC paths. When a UNC path is opened, Windows automatically attempts NTLM authentication to the remote host, causing the user’s NTLMv2 password hash to be leaked to an attacker-controlled SMB server. This can result in credential compromise through offline hash cracking. Impact If the following conditions are met, an attacker can get the NTLMv2 password hash on the computer that is using the launch-editor: - using Windows - NTLM is not disabled (it is recommended to disable, while it's still enabled by default) - the user accesses the attackers website that sends request to a middleware using launch-editor - the server that has the middleware using launch-editor is running - the attacker knows the URL for that server and the middleware This would be a problem if the user password is too simple that it can be identified through offline hash cracking, potentially leading to further compromise of developer…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v6wh-96g9-6wx3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v6wh-96g9-6wx3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53632 Advisory: launch-editor: NTLMv2 hash disclosure via UNC path handling on Windows IDs: CVE-2026-53632, GHSA-v6wh-96g9-6wx3 Record: https://patchnext.com/advisories/cve-2026-53632 (revision 3, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vite 8.0.16, 7.3.5, 6.4.3; vite-plus 0.1.24; launch-editor 2.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vite: affected >= 8.0.0, <= 8.0.15; >= 7.0.0, <= 7.3.4; <= 6.4.2; fixed in 7.3.5, 8.0.16, 6.4.3 - npm vite-plus: affected <= 0.1.23; fixed in 0.1.24 - npm launch-editor: affected <= 2.14.0; fixed in 2.14.1 ## Suggested inspection (read-only) - `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls vite-plus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls launch-editor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vite, vite-plus, launch-editor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v6wh-96g9-6wx3 (OSV record GHSA-v6wh-96g9-6wx3 lists affected ranges: npm launch-editor >=0 =8.0.0 =7.0.0 =0 =0 <0.1.24 (fixed)) - Verified: https://github.com/advisories/GHSA-v6wh-96g9-6wx3 (GitHub-reviewed advisory GHSA-v6wh-96g9-6wx3 lists affected ranges: npm launch-editor >=0 =8.0.0 =7.0.0 =0 =0 <=0.1.23) Commands are suggestions: review each one before running it.
Loading voting…