Skip to content

← Actionable
Critical, CVSS 9.1amended

Apostrophe has Server-Side Prototype Pollution in apos.util.set via patch operators that leads to process-wide authorization bypass

CVE-2026-53609GHSA-6h5j-32cf-4253

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.31.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
EPSS
  • CVE-2026-53609: 0.35% estimated exploitation activity in the next 30 days; percentile 28.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

<img width="1919" height="1046" alt="proto" src="https://github.com/user-attachments/assets/c5c69718-6448-448d-b64b-e3db41ab6ff6" / Summary apos.util.set() traverses dot-notation paths without sanitizing proto, allowing an authenticated editor to write arbitrary values to Object.prototype via the $pullAll patch operator. A confirmed gadget in publicApiCheck() causes this to bypass authorization on all piece-type REST API endpoints for every subsequent unauthenticated request, for the lifetime of the Node.js process. --- Details Root Cause — apos.util.set() (modules/@apostrophecms/util/index.js ~line 800) The function splits a dot-notation path and traverses properties without rejecting proto, constructor, or prototype: Source — implementPatchOperators() (modules/@apostrophecms/schema/index.js ~line 1737) User-controlled keys from the $pullAll operator are passed directly to apos.util.set(): cloneOriginalBase() does not sanitize proto because .has() performs an own-property check.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6h5j-32cf-4253

  2. Revision 2 · amended ·

    Amended from osv record GHSA-6h5j-32cf-4253

  3. Revision 1 · created ·

    Published from ghsa record GHSA-6h5j-32cf-4253

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53609

Advisory: Apostrophe has Server-Side Prototype Pollution in apos.util.set via patch operators that leads to process-wide authorization bypass
IDs: CVE-2026-53609, GHSA-6h5j-32cf-4253
Record: https://patchnext.com/advisories/cve-2026-53609 (revision 3, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.31.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm apostrophe: affected <= 4.30.0; fixed in 4.31.0

## Suggested inspection (read-only)
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6h5j-32cf-4253 (GitHub-reviewed advisory GHSA-6h5j-32cf-4253 lists affected ranges: npm apostrophe >=0 <=4.30.0)
- Verified: https://osv.dev/vulnerability/GHSA-6h5j-32cf-4253 (OSV record GHSA-6h5j-32cf-4253 lists affected ranges: npm apostrophe >=0 <4.31.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…