@apostrophecms/file pretty-URL Vulnerable to Unauthenticated SSRF via Host header
CVE-2026-53607GHSA-34pj-2622-jvxq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.31.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm apostrophe
- Affected
- <= 4.30.0
- Fixed in
- 4.31.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-34pj-2622-jvxq lists affected ranges: npm apostrophe >=0 <4.31.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-34pj-2622-jvxq lists affected ranges: npm apostrophe >=0 <=4.30.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-53607: 0.27% estimated exploitation activity in the next 30 days; percentile 19.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When prettyUrls: true is enabled on @apostrophecms/file (a documented SEO feature for serving uploaded files at clean URLs), the public pretty-URL handler builds the upstream URL using the raw Host HTTP request header: That URL is then fetch'ed and the response body + headers are streamed straight back to the requester. Because Host is fully attacker-controlled, an unauthenticated remote attacker can pivot the apostrophe process to issue outbound HTTP requests against any host it can reach on the private network. The path component is constrained to /uploads/attachments/<cuid-<slug.<ext (built from a local-DB lookup), which keeps the impact narrow: cross-instance data exfiltration is neutralised by cuid uniqueness, but blind-SSRF residuals remain (network-topology mapping via response-code / timing differences and verbose proxy/WAF 404 body disclosure). Verified on apostrophe@4.30.0 (latest); no fixed release exists. - Affected: apostrophe <= 4.30.0 when @apostrophecms/file…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-34pj-2622-jvxq
- Revision 1 · created ·
Published from osv record GHSA-34pj-2622-jvxq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53607 Advisory: @apostrophecms/file pretty-URL Vulnerable to Unauthenticated SSRF via Host header IDs: CVE-2026-53607, GHSA-34pj-2622-jvxq Record: https://patchnext.com/advisories/cve-2026-53607 (revision 2, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.31.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm apostrophe: affected <= 4.30.0; fixed in 4.31.0 ## Suggested inspection (read-only) - `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apostrophe. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-34pj-2622-jvxq (OSV record GHSA-34pj-2622-jvxq lists affected ranges: npm apostrophe >=0 <4.31.0 (fixed)) - Verified: https://github.com/advisories/GHSA-34pj-2622-jvxq (GitHub-reviewed advisory GHSA-34pj-2622-jvxq lists affected ranges: npm apostrophe >=0 <=4.30.0) Commands are suggestions: review each one before running it.
Loading voting…