Redaxo has a Mediapool isAllowedExtension bypass via multi-segment filename that leads to authenticated RCE on Apache mod_php multi-extension handlers
CVE-2026-53599GHSA-98pp-vccm-qm25
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (redaxo/source 5.21.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist redaxo/source
- Affected
- >= 5.18.2, < 5.21.1
- Fixed in
- 5.21.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-98pp-vccm-qm25 lists affected ranges: Packagist redaxo/source >=5.18.2 <5.21.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98pp-vccm-qm25 lists affected ranges: Packagist redaxo/source >=5.18.2 <5.21.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-53599: 0.51% estimated exploitation activity in the next 30 days; percentile 43.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary rexmediapool::isAllowedExtension in redaxo/src/addons/mediapool/lib/mediapool.php accepts filenames that contain a blocked extension as a non-terminal segment of a longer extension chain, for example shell.php.any.jpg. The check only catches the blocked extension when it appears at the end of the filename or immediately before the final extension. An authenticated backend user with mediapool upload permission can upload a JPEG/PHP polyglot named shell.php.any.jpg and, on web servers whose PHP handler matches .php as any segment (modmime AddHandler-style, or any FilesMatch regex without an end anchor), request the file from the public media/ directory to execute arbitrary PHP as the web-server user. The vulnerable check is a regression introduced in commit 9d008697d (PR #6213, Feb 7 2025), which weakened a previously correct strcontains check into a pair of strendswith checks. The earlier check, in place since 2018 specifically to defend against double-extension attacks, would…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-98pp-vccm-qm25
- Revision 1 · created ·
Published from osv record GHSA-98pp-vccm-qm25
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53599 Advisory: Redaxo has a Mediapool isAllowedExtension bypass via multi-segment filename that leads to authenticated RCE on Apache mod_php multi-extension handlers IDs: CVE-2026-53599, GHSA-98pp-vccm-qm25 Record: https://patchnext.com/advisories/cve-2026-53599 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: redaxo/source 5.21.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist redaxo/source: affected >= 5.18.2, < 5.21.1; fixed in 5.21.1 ## Suggested inspection (read-only) - Packagist redaxo/source: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on redaxo/source. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-98pp-vccm-qm25 (OSV record GHSA-98pp-vccm-qm25 lists affected ranges: Packagist redaxo/source >=5.18.2 <5.21.1 (fixed)) - Verified: https://github.com/advisories/GHSA-98pp-vccm-qm25 (GitHub-reviewed advisory GHSA-98pp-vccm-qm25 lists affected ranges: Packagist redaxo/source >=5.18.2 <5.21.1) Commands are suggestions: review each one before running it.
Loading voting…