Skip to content

← Actionable
High, CVSS 8.7amended

Prompty: Arbitrary code execution via JavaScript frontmatter in TypeScript loader

CVE-2026-53597GHSA-c4gh-rv8h-q9vw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@prompty/core 2.0.0-beta.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @prompty/core

    Affected
    >= 2.0.0-alpha.1, < 2.0.0-beta.3
    Fixed in
    2.0.0-beta.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-53597: 0.97% estimated exploitation activity in the next 30 days; percentile 62.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The TypeScript Prompty loader used gray-matter without overriding executable frontmatter engines. gray-matter supports JavaScript frontmatter blocks such as ---js and evaluates them while parsing. An attacker-controlled .prompty file could therefore execute arbitrary JavaScript during prompt loading. Affected package - npm @prompty/core v2 prerelease line: = 2.0.0-alpha.1 < 2.0.0-beta.3 - Fixed in @prompty/core@2.0.0-beta.3 The legacy v1 JavaScript runtime had a historical hardening change for this issue. During the v2 TypeScript runtime rebuild, the loader again called gray-matter directly and the vulnerable behavior was present in the v2 prerelease packages until 2.0.0-beta.3. Impact Applications that load untrusted .prompty files, user-provided prompt paths, or prompt bundles from less-trusted locations could execute arbitrary JavaScript in the host Node.js process during frontmatter parsing. Remediation Upgrade @prompty/core to 2.0.0-beta.3 or later. The fix explicitly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c4gh-rv8h-q9vw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c4gh-rv8h-q9vw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53597

Advisory: Prompty: Arbitrary code execution via JavaScript frontmatter in TypeScript loader
IDs: CVE-2026-53597, GHSA-c4gh-rv8h-q9vw
Record: https://patchnext.com/advisories/cve-2026-53597 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @prompty/core 2.0.0-beta.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @prompty/core: affected >= 2.0.0-alpha.1, < 2.0.0-beta.3; fixed in 2.0.0-beta.3

## Suggested inspection (read-only)
- `npm ls @prompty/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @prompty/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c4gh-rv8h-q9vw (OSV record GHSA-c4gh-rv8h-q9vw lists affected ranges: npm @prompty/core >=2.0.0-alpha.1 <2.0.0-beta.3 (fixed))
- Verified: https://github.com/advisories/GHSA-c4gh-rv8h-q9vw (GitHub-reviewed advisory GHSA-c4gh-rv8h-q9vw lists affected ranges: npm @prompty/core >=2.0.0-alpha.1 <2.0.0-beta.3)

Commands are suggestions: review each one before running it.

Loading voting…