Skip to content

← Actionable
Medium, CVSS 6.9amended

vite: server.fs.deny bypass on Windows alternate paths

CVE-2026-53571GHSA-fx2h-pf6j-xcff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 8.0.16, 7.3.5, 6.4.3; vite-plus 0.1.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vite

    Affected
    >= 8.0.0, < 8.0.16>= 7.0.0, < 7.3.5< 6.4.3
    Fixed in
    7.3.5, 8.0.16, 6.4.3
  • npm vite-plus

    Affected
    < 0.1.24
    Fixed in
    0.1.24

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-53571: 0.58% estimated exploitation activity in the next 30 days; percentile 47.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The contents of files that are specified by `server.fs.deny` can be returned to the browser on Windows.

Impact Only apps that match the following conditions are affected: - explicitly exposes the Vite dev server to the network (using `--host` or `server.host` config option) - the sensitive file exists in the allowed directories specified by `server.fs.allow` - either of: - the sensitive file exists in an NTFS volume - the dev server is running on Windows and the sensitive file exists in a volume that 8.3 short name generation is enabled (it is enabled by default on system volumes)

Details Vite’s dev server denies direct access to sensitive files through `server.fs.deny`, including entries such as `.env`, `.env.*`, and `*.{crt,pem}`. However, on Windows, the deny logic does not correctly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-fx2h-pf6j-xcff

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-fx2h-pf6j-xcff

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-fx2h-pf6j-xcff

  4. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 1 · created ·

    Published from osv record GHSA-fx2h-pf6j-xcff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53571

Advisory: vite: `server.fs.deny` bypass on Windows alternate paths
IDs: CVE-2026-53571, GHSA-fx2h-pf6j-xcff
Record: https://patchnext.com/advisories/cve-2026-53571 (revision 5, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vite 8.0.16, 7.3.5, 6.4.3; vite-plus 0.1.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vite: affected >= 8.0.0, < 8.0.16; >= 7.0.0, < 7.3.5; < 6.4.3; fixed in 7.3.5, 8.0.16, 6.4.3
- npm vite-plus: affected < 0.1.24; fixed in 0.1.24

## Suggested inspection (read-only)
- `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls vite-plus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vite, vite-plus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fx2h-pf6j-xcff (OSV record GHSA-fx2h-pf6j-xcff lists affected ranges: npm vite >=8.0.0 =7.0.0 =0 =0 <0.1.24 (fixed))
- Verified: https://github.com/advisories/GHSA-fx2h-pf6j-xcff (GitHub-reviewed advisory GHSA-fx2h-pf6j-xcff lists affected ranges: npm vite >=8.0.0 =7.0.0 =0 =0 <=0.1.23)

Commands are suggestions: review each one before running it.

Loading voting…