Skip to content

← Actionable
Medium, CVSS 5.3amended

JS-YAML: Quadratic-complexity DoS in merge key handling via repeated aliases

CVE-2026-53550GHSA-h67p-54hq-rp68

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (js-yaml 4.2.0, 3.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm js-yaml

    Affected
    >= 4.0.0, <= 4.1.1< 3.15.0
    Fixed in
    3.15.0, 4.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-53550: 0.41% estimated exploitation activity in the next 30 days; percentile 35.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A crafted YAML document can trigger algorithmic CPU exhaustion in js-yaml merge-key processing (<<) by repeating the same alias many times in a merge sequence. This causes quadratic parse-time behavior relative to input size and can block a Node.js worker/event loop for seconds with a relatively small payload (tens of KB), resulting in denial of service. Details The issue is in merge handling inside lib/loader.js: - storeMappingPair(...) iterates every element of a merge sequence when key tag is tag:yaml.org,2002:merge. - For each element, it calls mergeMappings(...). - mergeMappings(...) computes Object.keys(source) and performs hasOwnProperty.call(destination, key) checks for each key. When input is of the form: a: &a {k0:0, k1:0, ..., kK:0} b: {<<: [a, a, a, ... repeated M times ...]} all a entries refer to the same anchored object. After the first merge, subsequent merges are semantically no-ops, but the parser still reprocesses all keys each time. Resulting work is O(K…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h67p-54hq-rp68

  2. Revision 1 · created ·

    Published from osv record GHSA-h67p-54hq-rp68

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53550

Advisory: JS-YAML: Quadratic-complexity DoS in merge key handling via repeated aliases
IDs: CVE-2026-53550, GHSA-h67p-54hq-rp68
Record: https://patchnext.com/advisories/cve-2026-53550 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: js-yaml 4.2.0, 3.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm js-yaml: affected >= 4.0.0, <= 4.1.1; < 3.15.0; fixed in 3.15.0, 4.2.0

## Suggested inspection (read-only)
- `npm ls js-yaml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on js-yaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h67p-54hq-rp68 (OSV record GHSA-h67p-54hq-rp68 lists affected ranges: npm js-yaml >=4.0.0 =0 <3.15.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h67p-54hq-rp68 (GitHub-reviewed advisory GHSA-h67p-54hq-rp68 lists affected ranges: npm js-yaml >=4.0.0 =0 <3.15.0)

Commands are suggestions: review each one before running it.

Loading voting…