ratex-parser panics on \verb with a multibyte delimiter (UTF-8 byte-boundary slice)
CVE-2026-53530GHSA-4hgp-59h5-gvrj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ratex-parser 0.1.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io ratex-parser
- Affected
- < 0.1.11
- Fixed in
- 0.1.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4hgp-59h5-gvrj lists affected ranges: crates.io ratex-parser >=0 <0.1.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-53530: 0.43% estimated exploitation activity in the next 30 days; percentile 37.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The public parser entrypoint ratexparser::parse(&str) panics on the 9-byte input \verbéxé (i.e. \verb followed by the non-ASCII delimiter é). When handling a \verb command, the parser slices the verbatim argument with byte indices (arg[1..arg.len() - 1]); if the delimiter character is multibyte UTF-8, index 1 lands inside that character and Rust panics with “byte index 1 is not a char boundary”. Because RaTeX’s release profile sets panic = "abort" (Cargo.toml:48), the panic aborts the entire process — not just the current request/thread — making this a hard denial of service for any service that renders untrusted LaTeX. Details Affected code crates/ratex-parser/src/parser.rs, parsesymbolinner: For input \verbéxé: arg = "éxé", where é = U+00E9 (bytes C3 A9). arg.len() is the byte length (5), the < 2 guard passes, and arg[1..4] starts at byte index 1 — inside the first é (bytes 0..2) — so the slice panics. The lexer groups \verb<delim…<delim correctly with char semantics…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4hgp-59h5-gvrj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53530 Advisory: ratex-parser panics on `\verb` with a multibyte delimiter (UTF-8 byte-boundary slice) IDs: CVE-2026-53530, GHSA-4hgp-59h5-gvrj Record: https://patchnext.com/advisories/cve-2026-53530 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ratex-parser 0.1.11. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io ratex-parser: affected < 0.1.11; fixed in 0.1.11 ## Suggested inspection (read-only) - crates.io ratex-parser: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ratex-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4hgp-59h5-gvrj (GitHub-reviewed advisory GHSA-4hgp-59h5-gvrj lists affected ranges: crates.io ratex-parser >=0 <0.1.11) Commands are suggestions: review each one before running it.
Loading voting…