@better-auth/oauth-provider's OAuth authorization-code grant allows concurrent redemption when two token requests race the find-then-delete primitive
CVE-2026-53518GHSA-7w99-5wm4-3g79
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.6.11; @better-auth/oauth-provider 1.6.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- < 1.6.11
- Fixed in
- 1.6.11
npm @better-auth/oauth-provider
- Affected
- >= 1.6.0, < 1.6.11
- Fixed in
- 1.6.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7w99-5wm4-3g79 lists affected ranges: npm @better-auth/oauth-provider >=1.6.0 =0 <1.6.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7w99-5wm4-3g79 lists affected ranges: npm @better-auth/oauth-provider >=1.6.0 =0 <1.6.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-53518: 0.41% estimated exploitation activity in the next 30 days; percentile 35.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? Users are affected if all of the following are true: - Their project depends on @better-auth/oauth-provider at a version = 1.6.0, < 1.6.11, or uses the embedded plugin in better-auth = 1.4.8-beta.7, < 1.6.0, or enables the legacy oidc-provider or mcp plugins from better-auth/plugins. - Their application exposes /api/auth/oauth2/token (or the legacy plugins' /oauth2/token and /mcp/token) as a token endpoint to OAuth/OIDC clients, including internal MCP clients (Claude Desktop, custom MCP tool callers, AI agents). - Their application has not implemented an external mitigation: a load-balancer-level idempotency cache keyed by code, a database trigger that rejects duplicate token issuance for the same authorization code, or a custom adapter override that performs an atomic compare-and-delete. Fix: 1. Upgrade to @better-auth/oauth-provider@1.6.11 or later. If developers use the legacy plugin paths from better-auth/plugins, upgrade better-auth to 1.6.11 or later. 2. If…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7w99-5wm4-3g79
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7w99-5wm4-3g79
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53518 Advisory: @better-auth/oauth-provider's OAuth authorization-code grant allows concurrent redemption when two token requests race the find-then-delete primitive IDs: CVE-2026-53518, GHSA-7w99-5wm4-3g79 Record: https://patchnext.com/advisories/cve-2026-53518 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.6.11; @better-auth/oauth-provider 1.6.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected < 1.6.11; fixed in 1.6.11 - npm @better-auth/oauth-provider: affected >= 1.6.0, < 1.6.11; fixed in 1.6.11 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @better-auth/oauth-provider --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth, @better-auth/oauth-provider. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7w99-5wm4-3g79 (OSV record GHSA-7w99-5wm4-3g79 lists affected ranges: npm @better-auth/oauth-provider >=1.6.0 =0 <1.6.11 (fixed)) - Verified: https://github.com/advisories/GHSA-7w99-5wm4-3g79 (GitHub-reviewed advisory GHSA-7w99-5wm4-3g79 lists affected ranges: npm @better-auth/oauth-provider >=1.6.0 =0 <1.6.11) Commands are suggestions: review each one before running it.
Loading voting…