Better Auth has an account takeover issue via OAuth auto-link to unverified pre-registered email
CVE-2026-53516GHSA-g38m-r43w-p2q7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.6.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- < 1.6.11
- Fixed in
- 1.6.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g38m-r43w-p2q7 lists affected ranges: npm better-auth >=0 <1.6.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g38m-r43w-p2q7 lists affected ranges: npm better-auth >=0 <1.6.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
- EPSS
- CVE-2026-53516: 0.29% estimated exploitation activity in the next 30 days; percentile 21.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? Users are affected if all of the following are true: - Their application uses better-auth at a version < 1.6.11 on the stable line, or any current next pre-release. - emailAndPassword.enabled: true is set in their application's betterAuth({ ... }) configuration. - At least one OAuth or SSO provider is configured (any built-in social provider, or genericOAuth(...), or any provider via @better-auth/sso). - account.accountLinking.disableImplicitLinking is not set to true. - account.accountLinking.enabled is not set to false. Setting either disableImplicitLinking: true or enabled: false closes the hole at the cost of breaking the standard "add another login method" UX. emailAndPassword.requireEmailVerification: true does not mitigate, because the link-time emailVerified flip promotes the attacker's row to verified, after which the password login becomes usable. Fix: 1. Upgrade to better-auth@1.6.11 or later. 2. If developers cannot upgrade, see workarounds below. Summary…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g38m-r43w-p2q7
- Revision 1 · created ·
Published from osv record GHSA-g38m-r43w-p2q7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53516 Advisory: Better Auth has an account takeover issue via OAuth auto-link to unverified pre-registered email IDs: CVE-2026-53516, GHSA-g38m-r43w-p2q7 Record: https://patchnext.com/advisories/cve-2026-53516 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.6.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected < 1.6.11; fixed in 1.6.11 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g38m-r43w-p2q7 (OSV record GHSA-g38m-r43w-p2q7 lists affected ranges: npm better-auth >=0 <1.6.11 (fixed)) - Verified: https://github.com/advisories/GHSA-g38m-r43w-p2q7 (GitHub-reviewed advisory GHSA-g38m-r43w-p2q7 lists affected ranges: npm better-auth >=0 <1.6.11) Commands are suggestions: review each one before running it.
Loading voting…