Skip to content

← Actionable
High, CVSS 7.1amended

@better-auth/sso: SSO provider may allow registration for any org member without a checking their role

CVE-2026-53515GHSA-gv74-j8m3-fg5f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@better-auth/sso 1.6.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2026-53515: 0.43% estimated exploitation activity in the next 30 days; percentile 36.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? You are affected if all of the following are true: - You depend on @better-auth/sso at any version in = 1.2.10, < 1.6.11, or any current next pre-release. - You enable both sso() and organization() plugins. - providersLimit is at its default (10) or any non-zero value, so SSO provider registration is enabled for authenticated users. - An organization has non-admin members, or your application can add users to organizations as regular members. You are at the highest risk if any of these also hold: - Organization membership can be obtained without a direct admin decision, such as through open invitations, self-serve onboarding, public team joins, or SCIM bulk imports. - organizationProvisioning.defaultRole or organizationProvisioning.getRole returns admin or higher for SSO-provisioned users. The bug then becomes unauthorized admin creation in the org. - domainVerification.enabled is false (the default). The malicious provider is immediately usable. Fix: 1. Upgrade to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gv74-j8m3-fg5f

  2. Revision 1 · created ·

    Published from osv record GHSA-gv74-j8m3-fg5f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53515

Advisory: @better-auth/sso: SSO provider may allow registration for any org member without a checking their role
IDs: CVE-2026-53515, GHSA-gv74-j8m3-fg5f
Record: https://patchnext.com/advisories/cve-2026-53515 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @better-auth/sso 1.6.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @better-auth/sso: affected >= 1.2.10, < 1.6.11; fixed in 1.6.11

## Suggested inspection (read-only)
- `npm ls @better-auth/sso --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @better-auth/sso.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gv74-j8m3-fg5f (OSV record GHSA-gv74-j8m3-fg5f lists affected ranges: npm @better-auth/sso >=1.2.10 <1.6.11 (fixed))
- Verified: https://github.com/advisories/GHSA-gv74-j8m3-fg5f (GitHub-reviewed advisory GHSA-gv74-j8m3-fg5f lists affected ranges: npm @better-auth/sso >=1.2.10 <1.6.11)

Commands are suggestions: review each one before running it.

Loading voting…