Skip to content

← Actionable
High, CVSS 7.7amended

Better Auth vulnerable to unauthorized invitation acceptance via unverified email match in organization plugin

CVE-2026-53514GHSA-fmh4-wcc4-5jm3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.6.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-53514: 0.20% estimated exploitation activity in the next 30 days; percentile 10.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? Users are affected if all of the following are true: - Their application uses better-auth with the organization plugin (import { organization } from "better-auth/plugins/organization"). - Their application enables a sign-up surface that allows arbitrary unverified email registration. Most commonly emailAndPassword: { enabled: true } without requireEmailVerification: true. - Their application has not set requireEmailVerificationOnInvitation: true on the organization() options. - Their application invitation distribution flow allows anyone other than the invited mailbox owner to obtain the invitationId. Examples: admin UI surfacing the link, copy-paste into chat, forwarded email, mail-forwarding rules at the recipient's domain, link previews logging the URL, or a custom sendInvitationEmail integration that sends to a non-owner channel. If their application set emailAndPassword: { enabled: true, requireEmailVerification: true } so unverified rows cannot reach a usable…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fmh4-wcc4-5jm3

  2. Revision 1 · created ·

    Published from osv record GHSA-fmh4-wcc4-5jm3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53514

Advisory: Better Auth vulnerable to unauthorized invitation acceptance via unverified email match in organization plugin
IDs: CVE-2026-53514, GHSA-fmh4-wcc4-5jm3
Record: https://patchnext.com/advisories/cve-2026-53514 (revision 2, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.6.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected < 1.6.11; fixed in 1.6.11

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fmh4-wcc4-5jm3 (OSV record GHSA-fmh4-wcc4-5jm3 lists affected ranges: npm better-auth >=0 <1.6.11 (fixed))
- Verified: https://github.com/advisories/GHSA-fmh4-wcc4-5jm3 (GitHub-reviewed advisory GHSA-fmh4-wcc4-5jm3 lists affected ranges: npm better-auth >=0 <1.6.11)

Commands are suggestions: review each one before running it.

Loading voting…