@better-auth/sso provider registration has server-side request forgery via unvalidated OIDC endpoints
CVE-2026-53513GHSA-5rr4-8452-hf4v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@better-auth/sso 1.6.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @better-auth/sso
- Affected
- >= 0.1.0, < 1.6.11
- Fixed in
- 1.6.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5rr4-8452-hf4v lists affected ranges: npm @better-auth/sso >=0.1.0 <1.6.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5rr4-8452-hf4v lists affected ranges: npm @better-auth/sso >=0.1.0 <1.6.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-53513: 0.25% estimated exploitation activity in the next 30 days; percentile 16.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? Users are affected if all of the following are true: - Their application uses @better-auth/sso at a version = 0.1.0, < 1.6.11 on the stable line, or any 1.7.0-beta.x on the pre-release line. - The sso() plugin is added to their application's betterAuth({ plugins: [...] }) array. - Any user with a valid Better Auth session can reach POST /sso/register (the plugin's default gate accepts any session). For the non-blind SSRF impact (full IAM credential or internal HTTP body exfiltration), no further configuration is required. For the account takeover escalation, additionally: - Developers set sso({ trustEmailVerified: true, ... }). - The developer's application deployment has accounts whose email overlaps with attacker-chosen domains. If developers do not enable the SSO plugin, their application is not affected. Fix: 1. Upgrade to @better-auth/sso@1.6.11 or later. 2. If developers cannot upgrade, see workarounds below. Summary The @better-auth/sso plugin's POST…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5rr4-8452-hf4v
- Revision 2 · amended ·
Amended from osv record GHSA-5rr4-8452-hf4v
- Revision 1 · created ·
Published from ghsa record GHSA-5rr4-8452-hf4v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53513 Advisory: @better-auth/sso provider registration has server-side request forgery via unvalidated OIDC endpoints IDs: CVE-2026-53513, GHSA-5rr4-8452-hf4v Record: https://patchnext.com/advisories/cve-2026-53513 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @better-auth/sso 1.6.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @better-auth/sso: affected >= 0.1.0, < 1.6.11; fixed in 1.6.11 ## Suggested inspection (read-only) - `npm ls @better-auth/sso --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @better-auth/sso. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5rr4-8452-hf4v (GitHub-reviewed advisory GHSA-5rr4-8452-hf4v lists affected ranges: npm @better-auth/sso >=0.1.0 <1.6.11) - Verified: https://osv.dev/vulnerability/GHSA-5rr4-8452-hf4v (OSV record GHSA-5rr4-8452-hf4v lists affected ranges: npm @better-auth/sso >=0.1.0 <1.6.11 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…