ExifReader HEIC/AVIF ISO-BMFF parser throws uncaught RangeError on truncated boxes
CVE-2026-53496GHSA-g77h-45rf-hcx4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (exifreader 4.40.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm exifreader
- Affected
- <= 4.40.0
- Fixed in
- 4.40.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g77h-45rf-hcx4 lists affected ranges: npm exifreader >=0 <4.40.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g77h-45rf-hcx4 lists affected ranges: npm exifreader >=0 <=4.40.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-53496: 0.51% estimated exploitation activity in the next 30 days; percentile 43.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary ExifReader 4.40.0 can throw an uncaught RangeError: Offset is outside the bounds of the DataView while parsing crafted HEIC/AVIF files. The file only needs a valid leading ftyp box with a HEIC/AVIF major brand followed by a malformed ISO-BMFF box, such as an empty 8-byte free box or a truncated extended-size box. This is reachable through the public ExifReader.load() API for in-memory buffers and through the async file/URL loaders when an application parses attacker-supplied images. In applications that do not wrap every parse in a defensive try/catch, a single uploaded or fetched image can abort the request/worker and cause a denial of service. Credit requested: Yaohui Wang. Affected version tested - npm package: exifreader - Version: 4.40.0 - Repository commit tested: 8cb0261a26b7d986955fe0a6780f076dcb7902e7 Root cause The ISO-BMFF parser assumes that every top-level box with at least an 8-byte header also has enough bytes for the fields required by its parsed form. In…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g77h-45rf-hcx4
- Revision 1 · created ·
Published from osv record GHSA-g77h-45rf-hcx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53496 Advisory: ExifReader HEIC/AVIF ISO-BMFF parser throws uncaught RangeError on truncated boxes IDs: CVE-2026-53496, GHSA-g77h-45rf-hcx4 Record: https://patchnext.com/advisories/cve-2026-53496 (revision 2, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: exifreader 4.40.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm exifreader: affected <= 4.40.0; fixed in 4.40.1 ## Suggested inspection (read-only) - `npm ls exifreader --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on exifreader. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g77h-45rf-hcx4 (OSV record GHSA-g77h-45rf-hcx4 lists affected ranges: npm exifreader >=0 <4.40.1 (fixed)) - Verified: https://github.com/advisories/GHSA-g77h-45rf-hcx4 (GitHub-reviewed advisory GHSA-g77h-45rf-hcx4 lists affected ranges: npm exifreader >=0 <=4.40.0) Commands are suggestions: review each one before running it.
Loading voting…