Containerd has image-pull DoS via crafted OCI index graph amplification
CVE-2026-53493GHSA-pg57-6jwg-q645
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd/v2 2.4.1, 2.3.6, 2.2.9, 2.0.13; github.com/containerd/containerd 1.7.36), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/containerd/containerd/v2
- Affected
- >= 2.0.0, < 2.0.13>= 2.1.0, < 2.2.9>= 2.3.0, < 2.3.6>= 2.4.0, <= 2.4.0
- Fixed in
- 2.4.1, 2.0.13, 2.3.6, 2.2.9
Go github.com/containerd/containerd
- Affected
- <= 1.7.35
- Fixed in
- 1.7.36
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6597 lists affected ranges: Go github.com/containerd/containerd >=0 =2.0.0 =2.1.0 =2.3.0 =2.4.0 <2.4.1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pg57-6jwg-q645 lists affected ranges: Go github.com/containerd/containerd/v2 >=2.0.0 =2.1.0 =2.3.0 =2.4.0 =0 <1.7.36 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pg57-6jwg-q645 lists affected ranges: Go github.com/containerd/containerd/v2 >=2.0.0 =2.1.0 =2.3.0 =2.4.0 =0 <=1.7.35
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-53493: 0.36% estimated exploitation activity in the next 30 days; percentile 29.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability exists in containerd's image pull handlers where a crafted OCI image index containing deeply nested or heavily fanned-out descriptor graphs can cause unbounded CPU and memory consumption. During the PullImage operation, the recursive traversal and processing of child descriptors lack sufficient depth and breadth limits, and fail to adequately deduplicate identical descriptors. This unbounded traversal leads to excessive resource allocation. Consequently, pulling a malicious image reference can result in prolonged stalls during container creation and significant resource pressure on the host system. This issue occurs entirely during the image pull phase, prior to any container execution. Patches This bug has been fixed in containerd 2.4.1, 2.3.6, 2.2.9, 2.0.13, and 1.7.36. Users should update to these versions to resolve the issue. Workarounds There are no known workarounds for this issue. Users are advised to only pull trusted images from known registries until…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-pg57-6jwg-q645
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6597
- Revision 1 · created ·
Published from osv record GHSA-pg57-6jwg-q645
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53493 Advisory: Containerd has image-pull DoS via crafted OCI index graph amplification IDs: CVE-2026-53493, GHSA-pg57-6jwg-q645 Record: https://patchnext.com/advisories/cve-2026-53493 (revision 4, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd/v2 2.4.1, 2.3.6, 2.2.9, 2.0.13; github.com/containerd/containerd 1.7.36. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/containerd/containerd/v2: affected >= 2.0.0, < 2.0.13; >= 2.1.0, < 2.2.9; >= 2.3.0, < 2.3.6; >= 2.4.0, <= 2.4.0; fixed in 2.4.1, 2.0.13, 2.3.6, 2.2.9 - Go github.com/containerd/containerd: affected <= 1.7.35; fixed in 1.7.36 ## Suggested inspection (read-only) - Go github.com/containerd/containerd/v2: check the installed version with your package manager. - Go github.com/containerd/containerd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/containerd/containerd/v2, github.com/containerd/containerd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6597 (OSV record GO-2026-6597 lists affected ranges: Go github.com/containerd/containerd >=0 =2.0.0 =2.1.0 =2.3.0 =2.4.0 <2.4.1 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-pg57-6jwg-q645 (OSV record GHSA-pg57-6jwg-q645 lists affected ranges: Go github.com/containerd/containerd/v2 >=2.0.0 =2.1.0 =2.3.0 =2.4.0 =0 <1.7.36 (fixed)) - Verified: https://github.com/advisories/GHSA-pg57-6jwg-q645 (GitHub-reviewed advisory GHSA-pg57-6jwg-q645 lists affected ranges: Go github.com/containerd/containerd/v2 >=2.0.0 =2.1.0 =2.3.0 =2.4.0 =0 <=1.7.35) Commands are suggestions: review each one before running it.
Loading voting…