Skip to content

← Actionable
Medium, CVSS 4.3

Kite has an authenticated cluster RBAC bypass in /api/v1/overview

CVE-2026-53487GHSA-gvhc-wv3v-7pf8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/zxh326/kite 0.12.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-53487: 0.27% estimated exploitation activity in the next 30 days; percentile 19.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Authenticated Kite users with any role can request /api/v1/overview for a cluster that their roles do not permit by selecting that cluster with x-cluster-name. The overview route is registered before middleware.RBACMiddleware() and GetOverview only checks len(user.Roles) 0, so it returns aggregate Kubernetes inventory and capacity data from unauthorized clusters. The issue is present on current main commit 38c9bb9d4b746c0d2a8252f3c35cdfa07ab01c21 and latest release v0.12.2 at commit 0aae35abb2d6a8adf623fe60349261aa48753ccc. Impact A low-privileged user who only has access to one cluster can set x-cluster-name to another configured cluster and retrieve aggregate inventory and resource sizing data for that cluster. The response includes total node, pod, namespace, service, CPU, and memory values. This bypasses the cluster membership boundary used elsewhere in Kite. The validated impact is confidentiality only. I did not prove Kubernetes mutation, pod names, secret values,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gvhc-wv3v-7pf8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53487

Advisory: Kite has an authenticated cluster RBAC bypass in /api/v1/overview
IDs: CVE-2026-53487, GHSA-gvhc-wv3v-7pf8
Record: https://patchnext.com/advisories/cve-2026-53487 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/zxh326/kite 0.12.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/zxh326/kite: affected <= 0.12.2; fixed in 0.12.3

## Suggested inspection (read-only)
- Go github.com/zxh326/kite: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/zxh326/kite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gvhc-wv3v-7pf8 (GitHub-reviewed advisory GHSA-gvhc-wv3v-7pf8 lists affected ranges: Go github.com/zxh326/kite >=0 <=0.12.2)

Commands are suggestions: review each one before running it.

Loading voting…