Skip to content

← Actionable
Critical, CVSS 9.6amended

Openshift Migration Advisor agent-API fails to validate JWT source_id claim, allowing cross-tenant data manipulation

CVE-2026-53471GHSA-2fqw-7c6r-2cq6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubev2v/migration-planner 0.13.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-53471: 0.29% estimated exploitation activity in the next 30 days; percentile 21.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in migration-planner. The agent-API middleware processes JSON Web Tokens (JWTs) for authentication, but its UpdateSourceInventory and UpdateAgentStatus handlers fail to validate the sourceid claim within these tokens against the requested source ID. This oversight allows an authenticated attacker with a valid agent token to manipulate data across different tenants, leading to a complete collapse of tenant isolation. This could result in unauthorized overwriting of victim inventory, planting of malicious credential URLs, or corruption of migration assessments.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2fqw-7c6r-2cq6

  2. Revision 1 · created ·

    Published from osv record GO-2026-6228

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53471

Advisory: Openshift Migration Advisor agent-API fails to validate JWT source_id claim, allowing cross-tenant data manipulation
IDs: CVE-2026-53471, GHSA-2fqw-7c6r-2cq6
Record: https://patchnext.com/advisories/cve-2026-53471 (revision 2, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kubev2v/migration-planner 0.13.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kubev2v/migration-planner: affected < 0.13.5; fixed in 0.13.5

## Suggested inspection (read-only)
- Go github.com/kubev2v/migration-planner: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kubev2v/migration-planner.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6228 (OSV record GO-2026-6228 lists affected ranges: Go github.com/kubev2v/migration-planner >=0 <0.13.5 (fixed))
- Verified: https://github.com/advisories/GHSA-2fqw-7c6r-2cq6 (GitHub-reviewed advisory GHSA-2fqw-7c6r-2cq6 lists affected ranges: Go github.com/kubev2v/migration-planner >=0 <0.13.5)

Commands are suggestions: review each one before running it.

Loading voting…