Skip to content

← Actionable
Critical, CVSS 9.1amended

Apache Tomcat util accepted misconfigured CRLs

CVE-2026-53434GHSA-4x29-79gh-6v8q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-util 11.0.23, 10.1.56, 9.0.119), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat-util

    Affected
    >= 11.0.0-M1, <= 11.0.22>= 10.1.0-M7, <= 10.1.55>= 9.0.83, <= 9.0.118
    Fixed in
    10.1.56, 9.0.119, 11.0.23

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-53434: 0.59% estimated exploitation activity in the next 30 days; percentile 48.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Detection of Error Condition Without Action vulnerability in Apache Tomcat when configuring Certificate Revocation List (CRLs) for a FFM based connector. If an FFM connector was configured with invalid CRLs, the invalid CRLs were ignored meaning invalid certificates could be accepted. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M7 through 10.1.55, from 9.0.83 through 9.0.118. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4x29-79gh-6v8q

  2. Revision 1 · created ·

    Published from ghsa record GHSA-4x29-79gh-6v8q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-53434

Advisory: Apache Tomcat util accepted misconfigured CRLs
IDs: CVE-2026-53434, GHSA-4x29-79gh-6v8q
Record: https://patchnext.com/advisories/cve-2026-53434 (revision 2, source checked 26 Oct 2026, 16:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-util 11.0.23, 10.1.56, 9.0.119. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-util: affected >= 11.0.0-M1, <= 11.0.22; >= 10.1.0-M7, <= 10.1.55; >= 9.0.83, <= 9.0.118; fixed in 10.1.56, 9.0.119, 11.0.23

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-util: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-util.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4x29-79gh-6v8q (GitHub-reviewed advisory GHSA-4x29-79gh-6v8q lists affected ranges: Maven org.apache.tomcat:tomcat-util >=11.0.0-M1 =10.1.0-M7 =9.0.83 <=9.0.118)

Commands are suggestions: review each one before running it.

Loading voting…