Apache Tomcat's rewrite valve has an Always-Incorrect Control Flow Implementation vulnerability
CVE-2026-53404GHSA-h792-v28v-ppgr
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-catalina
- Affected
- >= 11.0.0-M1, < 11.0.23>= 10.1.0-M1, < 10.1.56>= 9.0.0.M1, < 9.0.119>= 8.5.0, <= 8.5.100
- Fixed in
- 10.1.56, 9.0.119, 11.0.23
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, < 11.0.23>= 10.1.0-M1, < 10.1.56>= 9.0.0.M1, < 9.0.119>= 8.5.0, <= 8.5.100
- Fixed in
- 10.1.56, 9.0.119, 11.0.23
Maven org.apache.tomcat:tomcat
- Affected
- >= 11.0.0-M1, < 11.0.23>= 10.1.0-M1, < 10.1.56>= 9.0.0.M1, < 9.0.119>= 8.5.0, <= 8.5.100
- Fixed in
- 10.1.56, 9.0.119, 11.0.23
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h792-v28v-ppgr lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 <=8.5.100
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat's rewrite valve meant that if the first condition in an OR chain matched, subsequent non-OR conditions were skipped. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h792-v28v-ppgr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53404 Advisory: Apache Tomcat's rewrite valve has an Always-Incorrect Control Flow Implementation vulnerability IDs: CVE-2026-53404, GHSA-h792-v28v-ppgr Record: https://patchnext.com/advisories/cve-2026-53404 (revision 1, source checked 4 Nov 2026, 17:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.23, 10.1.56, 9.0.119; org.apache.tomcat.embed:tomcat-embed-core 11.0.23, 10.1.56, 9.0.119; org.apache.tomcat:tomcat 11.0.23, 10.1.56, 9.0.119. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, < 11.0.23; >= 10.1.0-M1, < 10.1.56; >= 9.0.0.M1, < 9.0.119; >= 8.5.0, <= 8.5.100; fixed in 10.1.56, 9.0.119, 11.0.23 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.23; >= 10.1.0-M1, < 10.1.56; >= 9.0.0.M1, < 9.0.119; >= 8.5.0, <= 8.5.100; fixed in 10.1.56, 9.0.119, 11.0.23 - Maven org.apache.tomcat:tomcat: affected >= 11.0.0-M1, < 11.0.23; >= 10.1.0-M1, < 10.1.56; >= 9.0.0.M1, < 9.0.119; >= 8.5.0, <= 8.5.100; fixed in 10.1.56, 9.0.119, 11.0.23 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h792-v28v-ppgr (GitHub-reviewed advisory GHSA-h792-v28v-ppgr lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 <=8.5.100) Commands are suggestions: review each one before running it.
Loading voting…