Skip to content

← Actionable
Low, CVSS 1.9amended

a11y-mcp: Server-Side Request Forgery (SSRF) vulnerability in A11yServer function

CVE-2026-5323GHSA-prmx-7v35-7q82

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (a11y-mcp 1.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm a11y-mcp

    Affected
    < 1.0.5
    Fixed in
    1.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-5323: 0.13% estimated exploitation activity in the next 30 days; percentile 2.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in priyankark a11y-mcp up to 1.0.5. This vulnerability affects the function A11yServer of the file src/index.js. The manipulation results in server-side request forgery. The attack must be initiated from a local position. The exploit has been made public and could be used. This product operates on a rolling release basis, ensuring continuous delivery. Consequently, there are no version details for either affected or updated releases. Upgrading to version 1.0.6 is able to resolve this issue. The patch is identified as e3e11c9e8482bd06b82fd9fced67be4856f0dffc. It is recommended to upgrade the affected component. The vendor acknowledged the issue but provides additional context for the CVSS rating: "a11y-mcp is a local stdio MCP server - it has no HTTP endpoint and is not network-accessible. The caller is always the local user or an LLM acting on their behalf with user approval."

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-prmx-7v35-7q82

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-prmx-7v35-7q82

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-5323

Advisory: a11y-mcp: Server-Side Request Forgery (SSRF) vulnerability in A11yServer function
IDs: CVE-2026-5323, GHSA-prmx-7v35-7q82
Record: https://patchnext.com/advisories/cve-2026-5323 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: a11y-mcp 1.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm a11y-mcp: affected < 1.0.5; fixed in 1.0.5

## Suggested inspection (read-only)
- `npm ls a11y-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on a11y-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-prmx-7v35-7q82 (OSV record GHSA-prmx-7v35-7q82 lists affected ranges: npm a11y-mcp >=0 <1.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-prmx-7v35-7q82 (GitHub-reviewed advisory GHSA-prmx-7v35-7q82 lists affected ranges: npm a11y-mcp >=0 <1.0.5)

Commands are suggestions: review each one before running it.

Loading voting…