Formie Hidden field defaults vulnerable to Server-Side Template Injection
CVE-2026-52889GHSA-565m-g33j-jq96
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (verbb/formie 3.1.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist verbb/formie
- Affected
- < 3.1.27
- Fixed in
- 3.1.27
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-565m-g33j-jq96 lists affected ranges: Packagist verbb/formie >=0 <3.1.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-52889: 1.27% estimated exploitation activity in the next 30 days; percentile 69.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Formie Hidden fields could evaluate request-derived values as Twig during front-end form rendering. When a Hidden field used a dynamic default value such as HTTP User Agent, Referer URL, Current URL, Query Parameter, or Cookie Value, the value was copied from the incoming request and later passed to Craft’s Twig rendering layer. This allowed an unauthenticated attacker to provide Twig syntax in request-controlled input and have it evaluated server-side when the form was rendered. Affected Versions verbb/formie for Craft 5: - Affected: = 3.0.0-beta.1, <= 3.1.26 - Patched: 3.1.27 Impact An unauthenticated attacker could trigger server-side template evaluation by visiting a public form containing a Hidden field configured with a request-derived default value. Because Craft’s normal Twig environment exposes application objects, this may lead to disclosure of sensitive information, modification of application state, or remote code execution depending on the site configuration and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-565m-g33j-jq96
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52889 Advisory: Formie Hidden field defaults vulnerable to Server-Side Template Injection IDs: CVE-2026-52889, GHSA-565m-g33j-jq96 Record: https://patchnext.com/advisories/cve-2026-52889 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: verbb/formie 3.1.27. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist verbb/formie: affected < 3.1.27; fixed in 3.1.27 ## Suggested inspection (read-only) - Packagist verbb/formie: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on verbb/formie. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-565m-g33j-jq96 (GitHub-reviewed advisory GHSA-565m-g33j-jq96 lists affected ranges: Packagist verbb/formie >=0 <3.1.27) Commands are suggestions: review each one before running it.
Loading voting…