MantisBT: Reflected XSS in admin/install.php via unescaped printf
CVE-2026-52881GHSA-vcrw-4xvv-jh49
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.28.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mantisbt/mantisbt
- Affected
- <= 2.28.3
- Fixed in
- 2.28.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vcrw-4xvv-jh49 lists affected ranges: Packagist mantisbt/mantisbt >=0 <=2.28.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
MantisBT 2.28.3 and earlier contains six reflected XSS injection points in /admin/install.php. User-supplied parameters are echoed into HTML without escaping via an unescaped printf format string. No authentication is required. A Content Security Policy (script-src 'self') prevents inline JavaScript execution, but the CSP is missing a form-action directive, allowing exploitation via credential-phishing form injection and <meta open redirects. Impact - Credential phishing: Attacker crafts a URL that renders a fake login form on the real MantisBT admin page. Admin credentials are submitted to an attacker-controlled server. - Open redirect: Victim is silently redirected to a phishing or malware site. - UI manipulation: CSS injection can hide legitimate page content and overlay attacker-controlled HTML, enabling social engineering. Patches - https://github.com/mantisbt/mantisbt/commit/297773fbb238c39a153bd888431b41a176132098 Workarounds Remove the /admin directory, as recommended in the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vcrw-4xvv-jh49
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52881 Advisory: MantisBT: Reflected XSS in admin/install.php via unescaped printf IDs: CVE-2026-52881, GHSA-vcrw-4xvv-jh49 Record: https://patchnext.com/advisories/cve-2026-52881 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.28.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mantisbt/mantisbt: affected <= 2.28.3; fixed in 2.28.4 ## Suggested inspection (read-only) - Packagist mantisbt/mantisbt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mantisbt/mantisbt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vcrw-4xvv-jh49 (GitHub-reviewed advisory GHSA-vcrw-4xvv-jh49 lists affected ranges: Packagist mantisbt/mantisbt >=0 <=2.28.3) Commands are suggestions: review each one before running it.
Loading voting…