Skip to content

← Actionable
High, CVSS 7.1amended

MCP Python SDK: HTTP transports serve session requests without verifying the authenticated principal

CVE-2026-52869GHSA-jpw9-pfvf-9f58

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp 1.27.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mcp

    Affected
    <= 1.27.1
    Fixed in
    1.27.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-52869: 0.53% estimated exploitation activity in the next 30 days; percentile 45.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions, the SSE and Streamable HTTP server transports routed incoming requests to an existing session based only on the session identifier, without verifying that the request was authenticated as the same principal that created the session. Anyone who learned or guessed a session ID could send JSON-RPC messages on that session, regardless of which bearer token the request carried. Am I affected? Only if a developer's application server uses an HTTP transport (SSE, or Streamable HTTP in stateful mode) and authenticates requests. Servers on stdio, stateless Streamable HTTP, or with no authentication configured are not affected. Details Both transports look up the target session by its identifier alone — the sessionid query parameter for SSE (mcp.server.sse.SseServerTransport) and the Mcp-Session-Id header for Streamable HTTP (mcp.server.streamablehttpmanager.StreamableHTTPSessionManager). Once the lookup succeeded, the request was handled on that session without…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jpw9-pfvf-9f58

  2. Revision 1 · created ·

    Published from osv record GHSA-jpw9-pfvf-9f58

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52869

Advisory: MCP Python SDK: HTTP transports serve session requests without verifying the authenticated principal
IDs: CVE-2026-52869, GHSA-jpw9-pfvf-9f58
Record: https://patchnext.com/advisories/cve-2026-52869 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp 1.27.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp: affected <= 1.27.1; fixed in 1.27.2

## Suggested inspection (read-only)
- `python -m pip show mcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jpw9-pfvf-9f58 (OSV record GHSA-jpw9-pfvf-9f58 lists affected ranges: PyPI mcp >=0 <1.27.2 (fixed))
- Verified: https://github.com/advisories/GHSA-jpw9-pfvf-9f58 (GitHub-reviewed advisory GHSA-jpw9-pfvf-9f58 lists affected ranges: PyPI mcp >=0 <=1.27.1)

Commands are suggestions: review each one before running it.

Loading voting…