Skip to content

← Actionable
High, CVSS 7.5amended

Wings: Maliciously crafted packet during SFTP connection handshake causes denial of service

CVE-2026-52856GHSA-ghrq-5wpp-hxx5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pterodactyl/wings 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-52856: 0.61% estimated exploitation activity in the next 30 days; percentile 49.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A maliciously crafted packet received & parsed during the SFTP connection handshake will cause a Go panic. Impact All wings users with an open SFTP port. Workarounds Close SFTP port.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-ghrq-5wpp-hxx5

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6156

  3. Revision 1 · created ·

    Published from osv record GHSA-ghrq-5wpp-hxx5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52856

Advisory: Wings: Maliciously crafted packet during SFTP connection handshake causes denial of service
IDs: CVE-2026-52856, GHSA-ghrq-5wpp-hxx5
Record: https://patchnext.com/advisories/cve-2026-52856 (revision 3, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pterodactyl/wings 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pterodactyl/wings: affected < 1.13.0; fixed in 1.13.0

## Suggested inspection (read-only)
- Go github.com/pterodactyl/wings: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pterodactyl/wings.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ghrq-5wpp-hxx5 (OSV record GHSA-ghrq-5wpp-hxx5 lists affected ranges: Go github.com/pterodactyl/wings >=0 <1.13.0 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6156 (OSV record GO-2026-6156 lists affected ranges: Go github.com/pterodactyl/wings >=0 <1.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-ghrq-5wpp-hxx5 (GitHub-reviewed advisory GHSA-ghrq-5wpp-hxx5 lists affected ranges: Go github.com/pterodactyl/wings >=0 <1.13.0)

Commands are suggestions: review each one before running it.

Loading voting…