Skip to content

← Actionable
High, CVSS 8.6

mediawiki/maps has stored XSS through the overlays parameter in the display_map parser function

CVE-2026-52854GHSA-4h7g-5542-v3fc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/maps 12.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-52854: 0.58% estimated exploitation activity in the next 30 days; percentile 47.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Stored XSS through wikitext can be performed by inserting malicious HTML into the overlays parameter of the displaymap parser function when using the leaflet service. Details The maps extension doesn't escape overlay names before passing them to leaflet. Leaflet then inserts them as HTML: https://github.com/ProfessionalWiki/Maps/blob/ca5139fabd75f3c34f47ea3fd161306506b053bc/resources/lib/leaflet/leaflet.js#L5243 PoC Preview the following wikitext, using the default configuration options of the extension: Impact Stored XSS can be performed by any user with the edit permission.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4h7g-5542-v3fc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52854

Advisory: mediawiki/maps has stored XSS through the overlays parameter in the display_map parser function
IDs: CVE-2026-52854, GHSA-4h7g-5542-v3fc
Record: https://patchnext.com/advisories/cve-2026-52854 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mediawiki/maps 12.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mediawiki/maps: affected < 12.1.3; fixed in 12.1.3

## Suggested inspection (read-only)
- Packagist mediawiki/maps: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mediawiki/maps.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4h7g-5542-v3fc (GitHub-reviewed advisory GHSA-4h7g-5542-v3fc lists affected ranges: Packagist mediawiki/maps >=0 <12.1.3)

Commands are suggestions: review each one before running it.

Loading voting…