Caddy: FastCGI header normalization bypass in forward_auth copy_headers
CVE-2026-52845GHSA-f59h-q822-g45g
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/caddyserver/caddy/v2
- Affected
- < 2.11.4
- Fixed in
- 2.11.4
Go github.com/caddyserver/caddy
- Affected
- <= 1.0.5
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f59h-q822-g45g lists affected ranges: Go github.com/caddyserver/caddy/v2 >=0 =0 <=1.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-52845: 0.45% estimated exploitation activity in the next 30 days; percentile 38.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary forwardauth copyheaders deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through phpfastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with . This lets a client send an underscore alias that survives the forwardauth delete step but becomes the same PHP/FastCGI variable: Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. Details forwardauth copyheaders intentionally removes client-controlled headers before setting values from the auth response: - modules/caddyhttp/reverseproxy/forwardauth/caddyfile.go:212 - modules/caddyhttp/reverseproxy/forwardauth/caddyfile.go:222 That delete is exact-field deletion through http.Header.Del(): - modules/caddyhttp/headers/headers.go:255 - modules/caddyhttp/headers/headers.go:281 So deleting Remote-Groups does not delete RemoteGroups. Later, FastCGI exports…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f59h-q822-g45g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52845 Advisory: Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` IDs: CVE-2026-52845, GHSA-f59h-q822-g45g Record: https://patchnext.com/advisories/cve-2026-52845 (revision 1, source checked 26 Oct 2026, 15:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/caddyserver/caddy/v2 2.11.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/caddyserver/caddy/v2: affected < 2.11.4; fixed in 2.11.4 - Go github.com/caddyserver/caddy: affected <= 1.0.5 ## Suggested inspection (read-only) - Go github.com/caddyserver/caddy/v2: check the installed version with your package manager. - Go github.com/caddyserver/caddy: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/caddyserver/caddy/v2, github.com/caddyserver/caddy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f59h-q822-g45g (GitHub-reviewed advisory GHSA-f59h-q822-g45g lists affected ranges: Go github.com/caddyserver/caddy/v2 >=0 =0 <=1.0.5) Commands are suggestions: review each one before running it.
Loading voting…