Skip to content

← Actionable
Medium, CVSS 5.3

Kimai: ExportTemplate CRUD Missing Authorization Check Allows Unauthorized TEAMLEAD Access

CVE-2026-52828GHSA-rw46-qg69-vg6h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.58.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-52828: 0.46% estimated exploitation activity in the next 30 days; percentile 40.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The ExportController web routes for creating and editing export templates are gated only by the class-level createexport permission, which is granted to ROLETEAMLEAD by default. The corresponding API routes and UI button visibility correctly require the stricter createexporttemplate permission, which is granted only to ROLEADMIN and ROLESUPERADMIN. A TEAMLEAD user can directly access the template create/edit routes to create or modify global export templates that are visible to all users including administrators. Details The ExportController applies the class-level annotation #[IsGranted('createexport')]. The createExportTemplate (line 210) and editExportTemplate (line 220) methods have no method-level #[IsGranted('createexporttemplate')] annotation. The permission hierarchy in config/packages/kimai.yaml:103,115,122-123 grants createexport to ROLETEAMLEAD via the EXPORT permission set, but createexporttemplate only to ROLEADMIN and ROLESUPERADMIN. The API controller correctly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rw46-qg69-vg6h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52828

Advisory: Kimai: ExportTemplate CRUD Missing Authorization Check Allows Unauthorized TEAMLEAD Access
IDs: CVE-2026-52828, GHSA-rw46-qg69-vg6h
Record: https://patchnext.com/advisories/cve-2026-52828 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.58.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist kimai/kimai: affected <= 2.57.0; fixed in 2.58.0

## Suggested inspection (read-only)
- Packagist kimai/kimai: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kimai/kimai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rw46-qg69-vg6h (GitHub-reviewed advisory GHSA-rw46-qg69-vg6h lists affected ranges: Packagist kimai/kimai >=0 <=2.57.0)

Commands are suggestions: review each one before running it.

Loading voting…