Skip to content

← Actionable
High, CVSS 7.0amended

Linuxfabrik Monitoring Plugins: Sudoers may be able to obtain privilege escalation via /usr/bin/apt-get arguments

CVE-2026-52817GHSA-8w6w-23mq-h8rg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (linuxfabrik-lib 5.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-52817: 0.18% estimated exploitation activity in the next 30 days; percentile 7.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In the Debian.sudoers file, apt-get is allowed for the nagios user. The full command including the arguments are not enforced and can therefore be choosen arbitrarily. This allows to easily get a root shell as the nagios user: PoC By choosing a particular argument, you can get (as a nagios user) a root shell: Since the nagious user can use sudo to run apt-get as root, the resulting shell is also running as root. Impact The vulnerability is a local privilege escalation, impacting users who use the provided sudoers file. It requires that an attacker already compromised the nagios account (which is quite a high barrier to be honest). Fix Since only one place where apt-get is currently used (in deb-updates) was found, it should be enough to allow only the specific arguments used there. Here an example how the line in the sudoers file could look like:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8w6w-23mq-h8rg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8w6w-23mq-h8rg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52817

Advisory: Linuxfabrik Monitoring Plugins: Sudoers may be able to obtain privilege escalation via /usr/bin/apt-get arguments
IDs: CVE-2026-52817, GHSA-8w6w-23mq-h8rg
Record: https://patchnext.com/advisories/cve-2026-52817 (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: linuxfabrik-lib 5.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI linuxfabrik-lib: affected <= 5.0.0; fixed in 5.1.0

## Suggested inspection (read-only)
- `python -m pip show linuxfabrik-lib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on linuxfabrik-lib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8w6w-23mq-h8rg (OSV record GHSA-8w6w-23mq-h8rg lists affected ranges: PyPI linuxfabrik-lib >=0 <5.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8w6w-23mq-h8rg (GitHub-reviewed advisory GHSA-8w6w-23mq-h8rg lists affected ranges: PyPI linuxfabrik-lib >=0 <=5.0.0)

Commands are suggestions: review each one before running it.

Loading voting…