Skip to content

← Actionable
Medium, CVSS 5.4

Gogs's Unauthenticated Jupyter Notebook (ipynb) Sanitizer allows arbitrary data: URIs leading to XSS

CVE-2026-52816GHSA-3w28-36p9-w929

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogs.io/gogs 0.14.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:P · score source
EPSS
  • CVE-2026-52816: 0.68% estimated exploitation activity in the next 30 days; percentile 52.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Jupyter Notebook (ipynb) sanitizer endpoint at POST /-/api/sanitizeipynb allows arbitrary data: URIs without proper restrictions, potentially leading to Cross-Site Scripting (XSS). The endpoint uses bluemonday.UGCPolicy() with p.AllowURLSchemes("data") which permits all data URI schemes including data:text/html, enabling attackers to inject malicious HTML/JavaScript. Additionally, the endpoint has no authentication middleware, allowing any registered user to exploit this vulnerability. Severity High Affected Versions All versions using the vulnerable endpoint Vulnerability Details - CVE ID: (To be assigned) - Entry Point: POST /-/api/sanitizeipynb - Attack Vector: Network - Authentication Required: No (only needs a registered user account) Impact An attacker with a registered user account can: - Send malicious HTML containing data:text/html URIs to the sanitization endpoint - Receive sanitized but attacker-controlled HTML in the response - Execute arbitrary JavaScript in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3w28-36p9-w929

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52816

Advisory: Gogs's Unauthenticated Jupyter Notebook (ipynb) Sanitizer allows arbitrary data: URIs leading to XSS
IDs: CVE-2026-52816, GHSA-3w28-36p9-w929
Record: https://patchnext.com/advisories/cve-2026-52816 (revision 1, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gogs.io/gogs 0.14.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go gogs.io/gogs: affected < 0.14.3; fixed in 0.14.3

## Suggested inspection (read-only)
- Go gogs.io/gogs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gogs.io/gogs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3w28-36p9-w929 (GitHub-reviewed advisory GHSA-3w28-36p9-w929 lists affected ranges: Go gogs.io/gogs >=0 <0.14.3)

Commands are suggestions: review each one before running it.

Loading voting…