Skip to content

← Actionable
Medium, CVSS 5.5

Gogs Vulnerable to Unauthenticated Organization Teams Information Disclosure via API

CVE-2026-52815GHSA-744x-3838-5r56

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogs.io/gogs 0.14.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-52815: 1.49% estimated exploitation activity in the next 30 days; percentile 74.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Gogs has an unauthenticated information disclosure vulnerability. The GET /api/v1/orgs/:orgname/teams endpoint at internal/route/api/v1/orgteam.go:8 returns all teams for any organization without requiring authentication. The route group at internal/route/api/v1/api.go:380-385 lacks the reqToken() middleware, and the listTeams() handler performs no authentication check, exposing team IDs, names, descriptions, and permission levels to any unauthenticated caller. Affected Versions Gogs (all current versions) Vulnerability Details Root Cause: Missing reqToken() middleware on org teams route group internal/route/api/v1/api.go lines 380-385: The orgAssignment(true) middleware only loads the organization object — it performs no authentication. The listTeams() handler at orgteam.go:8 returns all teams unconditionally: Compare with other org endpoints that correctly require authentication: Attack Chain - Attacker sends GET /api/v1/orgs/target-org/teams with no authentication -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-744x-3838-5r56

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52815

Advisory: Gogs Vulnerable to Unauthenticated Organization Teams Information Disclosure via API
IDs: CVE-2026-52815, GHSA-744x-3838-5r56
Record: https://patchnext.com/advisories/cve-2026-52815 (revision 1, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gogs.io/gogs 0.14.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go gogs.io/gogs: affected < 0.14.3; fixed in 0.14.3

## Suggested inspection (read-only)
- Go gogs.io/gogs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gogs.io/gogs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-744x-3838-5r56 (GitHub-reviewed advisory GHSA-744x-3838-5r56 lists affected ranges: Go gogs.io/gogs >=0 <0.14.3)

Commands are suggestions: review each one before running it.

Loading voting…