Gogs vulnerable to RCE via git rebase --exec argument injection in pull request merge
CVE-2026-52806GHSA-qf6p-p7ww-cwr9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogs.io/gogs 0.14.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go gogs.io/gogs
- Affected
- < 0.14.3
- Fixed in
- 0.14.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qf6p-p7ww-cwr9 lists affected ranges: Go gogs.io/gogs >=0 <0.14.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-52806: 7.93% estimated exploitation activity in the next 30 days; percentile 94.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Gogs: RCE via git rebase --exec Argument Injection in PR Merge Summary Gogs allows authenticated users to achieve Remote Code Execution (RCE) on the server by creating a pull request with a specially crafted branch name that injects the --exec flag into the git rebase command during the "Rebase before merging" merge operation. Severity Critical - CVSS 3.1 Base Score: 9.9 (AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H) Affected Versions - Gogs 0.14.2 (latest supported release) - Gogs 0.15.0+dev (commit b53d3162, main branch as of 2026-03-16) - All prior versions that support the "Rebase before merging" merge style Impact This is a privilege escalation from authenticated user to server-level code execution. The attacker uses their own repository as the delivery mechanism - the target is not the repository but the Gogs server itself. On any multi-tenant Gogs instance (company, university, open source hosting), this gives one authenticated user full control of the underlying server: - Server…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qf6p-p7ww-cwr9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52806 Advisory: Gogs vulnerable to RCE via git rebase --exec argument injection in pull request merge IDs: CVE-2026-52806, GHSA-qf6p-p7ww-cwr9 Record: https://patchnext.com/advisories/cve-2026-52806 (revision 1, source checked 26 Oct 2026, 15:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gogs.io/gogs 0.14.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go gogs.io/gogs: affected < 0.14.3; fixed in 0.14.3 ## Suggested inspection (read-only) - Go gogs.io/gogs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gogs.io/gogs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qf6p-p7ww-cwr9 (GitHub-reviewed advisory GHSA-qf6p-p7ww-cwr9 lists affected ranges: Go gogs.io/gogs >=0 <0.14.3) Commands are suggestions: review each one before running it.
Loading voting…