Skip to content

← Actionable
Medium, CVSS 5.5

Gogs Vulnerable to Privilege Escalation via Collaboration Access Mode Validation

CVE-2026-52804GHSA-4565-r4x7-hg8j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogs.io/gogs 0.14.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-52804: 0.50% estimated exploitation activity in the next 30 days; percentile 42.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A repository admin collaborator can escalate their privileges to owner-level access by exploiting an off-by-one error in the ChangeCollaborationAccessMode function. Vulnerable Code In internal/database/repocollaboration.go, line 129: AccessModeOwner has value 4. The check mode AccessModeOwner evaluates to 4 4 = false, allowing AccessModeOwner to pass through. The correct check should be mode = AccessModeOwner. The web route at internal/route/repo/setting.go:413-416 takes the mode as a raw integer from query parameters: This allows an admin collaborator to POST mode=4 and escalate to owner. Impact A repository admin collaborator (AccessModeAdmin = 3) can escalate to owner-level access (AccessModeOwner = 4), gaining the ability to: - Delete the repository - Transfer repository ownership to another user - Erase wiki data - Perform all other owner-only operations The access table is also updated (line 181), so the escalated permissions persist across sessions. Contrast The API…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4565-r4x7-hg8j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-52804

Advisory: Gogs Vulnerable to Privilege Escalation via Collaboration Access Mode Validation
IDs: CVE-2026-52804, GHSA-4565-r4x7-hg8j
Record: https://patchnext.com/advisories/cve-2026-52804 (revision 1, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gogs.io/gogs 0.14.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go gogs.io/gogs: affected < 0.14.3; fixed in 0.14.3

## Suggested inspection (read-only)
- Go gogs.io/gogs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gogs.io/gogs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4565-r4x7-hg8j (GitHub-reviewed advisory GHSA-4565-r4x7-hg8j lists affected ranges: Go gogs.io/gogs >=0 <0.14.3)

Commands are suggestions: review each one before running it.

Loading voting…