Froxlor's API Authentication bypasses 2FA Authentication
CVE-2026-52793GHSA-f9rx-7wf7-jr36
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (froxlor/froxlor 2.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist froxlor/froxlor
- Affected
- < 2.3.7
- Fixed in
- 2.3.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f9rx-7wf7-jr36 lists affected ranges: Packagist froxlor/froxlor >=0 <2.3.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-52793: 0.33% estimated exploitation activity in the next 30 days; percentile 25.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Froxlor's API authentication (FroxlorRPC::validateAuth) does not enforce Two-Factor Authentication. When a user (admin or customer) enables 2FA on their account, the web UI correctly requires a TOTP code after password verification. However, the API accepts requests authenticated with only an API key and secret — no TOTP challenge is issued, checked, or required. An attacker who obtains a leaked API key+secret for a 2FA-protected account has full access to all API operations without providing a second factor. Affected Code Web UI — 2FA enforced (index.php:82-149): API — 2FA absent (lib/Froxlor/Api/FroxlorRPC.php:75-105): There are zero references to 2FA, TOTP, type2fa, or FroxlorTwoFactorAuth in the entire lib/Froxlor/Api/ directory: PoC Environment - Froxlor 2.3.5, clean Docker install (Debian Bookworm, PHP 8.2, Apache 2.4) - API enabled (api.enabled=1) - Admin account has 2FA enabled (type2fa=1, TOTP configured) - Admin has an API key Step 1: Confirm 2FA blocks web UI login…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f9rx-7wf7-jr36
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-52793 Advisory: Froxlor's API Authentication bypasses 2FA Authentication IDs: CVE-2026-52793, GHSA-f9rx-7wf7-jr36 Record: https://patchnext.com/advisories/cve-2026-52793 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: froxlor/froxlor 2.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist froxlor/froxlor: affected < 2.3.7; fixed in 2.3.7 ## Suggested inspection (read-only) - Packagist froxlor/froxlor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on froxlor/froxlor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f9rx-7wf7-jr36 (GitHub-reviewed advisory GHSA-f9rx-7wf7-jr36 lists affected ranges: Packagist froxlor/froxlor >=0 <2.3.7) Commands are suggestions: review each one before running it.
Loading voting…